powered by Jive Software

LDAP vCard isn''t showing email from AD

I actually found the solution to this problem at this link here http://www.jivesoftware.org/community/thread.jspa?messageID=112789 but unfortunately it seems that the forum has stripped the important parts of the messages that would indicate which vcard mappings need to be modified.

If someone would be kind enough to repost this info it would be greatly appreciated.

Message was edited by: agentdr8

No one can repost the requested info? How about if I say please?

Here’'s what I have in my wildfire.xml in the vcard-mapping section:

/code

And it would seem that Spark is the client having issues w/ this, as Pandion sees the email address just fine.

I have the same Problem with LDAP vCard Integration. I’‘ve managed to get all the Business Information, but i’'ve got stuck at the Email Field,too.

It woluld be really great if someone could post the solution once more.

Thanks a lot in advance!

Greets,

Coffein

Here is what works for me using Spark. Hope it helps…

<vcard-mapping>

<![CDATA[

<vCard xmlns=’‘vcard-temp’’>

<FN attrs=“displayName”></FN> <N> <FAMILY attrs=“sn”></FAMILY>

<GIVEN attrs=“givenName”></GIVEN> <MIDDLE/> </N> <NICKNAME attrs=“sAMAccountName”></NICKNAME>

<TEL><VOICE/><HOME/><NUMBER attrs=“homePhone”></NUMBER></TEL> <ADR><WORK/><STREET attrs=“streetAddress”></STREET></ADR>

<ADR><WORK/><POBOX attrs=“postOfficeBox”></POBOX></ADR> <ADR><WORK/><LOCALITY attrs=“l”></LOCALITY></ADR>

<ADR><WORK/><REGION attrs=“st”></REGION></ADR> <ADR><WORK/><PCODE attrs=“postalCode”></PCODE></ADR>

<ADR><WORK/><CTRY attrs=“co”></CTRY></ADR> <TEL><VOICE/><WORK/><NUMBER attrs=“telephoneNumber”></NUMBER></TEL>

<TEL><FAX/><WORK/><NUMBER attrs=“facsimileTelephoneNumber”></NUMBER></TEL> <TEL><CELL/><WORK/><NUMBER attrs=“mobile”></NUMBER></TEL>

<EMAIL><INTERNET/><USERID attrs=“mail”></USERID></EMAIL> <EMAIL><WORK/><USERID attrs=“mail”></USERID></EMAIL>

<EMAIL><HOME/><USERID attrs=“mail”></USERID></EMAIL>
<TITLE attrs=“title”></TITLE>

<ROLE attrs=“Rank”></ROLE> <ORG> <ORGNAME attrs=“company”></ORGNAME>

<ORGUNIT attrs=“department”></ORGUNIT> </ORG> <URL attrs=“wWWHomePage”></URL>

<DESC attrs=“description”></DESC>

</vCard>]]>

</vcard-mapping>

Message was edited by: rdale

Thanks a lot rdale for the Quick answer!

With the setting you provided it’'s working great.

You really made my day

Greets,

Coffein

Awesome, that’'s just what I was looking for.

Thanks!