powered by Jive Software

List of supported clients?

Hello,

I haven’t found this question in any other category, and I think this the apropriate one to host it.

I’ve installed two Openfire servers on two different machines, in two different networks (one is inside a LAN an the other on a DMZ / public network. They see each other, but I think this does not count for my question).

I only am able to connect to both of these servers by using the Spark IM client. I’ve tried Pandion (which is currently used in our company alongside a Wildfire 3.1.1 server), Psi, Exodus, Coccinella and a few others, without any chance of success.

The Openfire servers were installed in version 3.3.2. At that time, Exodus and Coccinella were still able to connect.

They’re now updated to versions 3.4.1 and lately 3.4.3 (both), and I can only connect using Spark.

The servers use a SSL self-signed certificate, but so does the old Wildfire (who does accept connections from any of the above mentioned clients).

Does anyone know of any reason why the other clients would not connect?

Thanks in advance.

Alin F.

Any XMPP client should work, and all the ones you listed are known to work. What sort of errors are you getting?

Exodus is working for me with 3.4.1 and 3.4.3 (without SSL). Maybe you can try disabling SSL and see if that changes anything?

in your openfire.xml file, do you have a <mechs> section. If you do you may need to add additional authentication mechs in there. For example: <mechs>GSSAPI,CRAM-MD5,DIGEST-MD5,PLAIN,EXTERNAL</mechs>

Yes, I know that any xmpp client should work, but they don’t

I do get this output in the “Debug” section of the logs, on the server side:

yyyy.mm.dd hh:mm:ss JettyLog: EXCEPTION

javax.net.ssl.SSLException: Inbound closed before receiving peer’s close_notify: possible truncation attack?

at com.sun.net.ssl.internal.ssl.Alerts.getSSLException(Unknown Source)

at com.sun.net.ssl.internal.ssl.SSLEngineImpl.fatal(Unknown Source)

at com.sun.net.ssl.internal.ssl.SSLEngineImpl.fatal(Unknown Source)

at com.sun.net.ssl.internal.ssl.SSLEngineImpl.closeInbound(Unknown Source)

at org.mortbay.jetty.security.SslHttpChannelEndPoint.fill(SslHttpChannelEndPoint.j ava:448)

at org.mortbay.jetty.security.SslHttpChannelEndPoint.fill(SslHttpChannelEndPoint.j ava:200)

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:282)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:205)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:381)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:396)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442)

yyyy.mm.dd hh:mm:ss JettyLog: EOF

The client used is Psi, version 0.11

Does this log give you any hint?..

Thanks,

Alin F.

Oh, almost forgot: on the client side, I get no result. It only sais “Connecting…”, and I don’t even get a timeout, even after 5-10 minutes of waiting.

wr00t: I haven’t yet tried without the SSL fonction, but the thing is that, when I try to connect with Psi to one of the servers, it does give me e warning message regarding the self-signed certificate. It’s curious thow that I don’t get the same message when trying to connect to the other, since they both have self-signed certificates.

mtstravel,I don’t have the specified line in the server.xml file. Can you point to me the zone where the line should be set in the file, or the position doesn’t matter ?

Thanks.

Hey Alin,

The stack trace is indicating that your client is not trying to connect to port 5222 but to the port of the admin console or may be the http binding port. Are you trying to use http binding to connect to the server? BTW, Openfire does not support http polling in case you are trying to use that.

Regards,

– Gato

Hey,

I’m only trying to connect to the server by any “default” way. I mean, I do not need any special connection binding.

I let the client connect using it’s default settings. I did override them by forcing the connection port (5222), but still the same result.

I tried connectong with the Exodus client, and I get to connect to each server. By using Pandion, I get the same error message.

As a different idea, we plan using this server for an internal webchat, which works fine for the moment (there is an apache http web server that hosts a site, and a tomcat module that makes the link between my openfire and the web server). I only configured the server for the basic web-client connections, and that works just fine.

Thanks,

Alin F.