powered by Jive Software

Locked out from 3.7.1 admin UI since changing the Server name

Hi,

We had successfully set-up Openfire 3.7.1 on Windows 2008 R2 with an external MS SQL server and all was well.

Our domain name was set-up: chat.domainname.com, and the server name was taken from the machines hostname. E.g. server1


After pulling in the users from AD we set-up a few admins with a JID such as jbloggs@server1


In an attempt to try and make it easier for the users to sign-in with their various clients we changed the server name to match that of the domain, and then restarted the service.

Server name FROM: server1

Server name TO: chat.domainname.com


We then tried to log on to the admin webpage and keep getting the following error: Login failed: make sure your username and password are correct and that you’re an admin or moderator.

I was wondering if there was a way of getting out of this mess without having to lose any settings?

NB: We’ve tried adding the following to the openfire.xml file but to no avail:

Thanks,

RL

Message was edited by: Rufus

You may have to edit the database to solve this one

authorizedJIDs is stored in the database. Find the record, delete it and rerun setup