powered by Jive Software

Log in users witn Windows 2003 SP1

Help, i just installed de WildFire 2.4.0 on my Windows 2003 SP1 Server, and everytime one user wants to log in i get this error:

Exception in thread “pool-2-thread-1” java.lang.NullPointerException

at org.jivesoftware.wildfire.spi.RoutingTableImpl.getRoute(RoutingTableImpl.java:8 3)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.returnErrorToSender(Out goingSessionPromise.java:153)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.access$400(OutgoingSess ionPromise.java:37)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise$1$1.run(OutgoingSession Promise.java:94)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Has someone and idea?

I have installed Java 5

Hi Rafael,

What client are you trying to connect with? Have you tried using url=http://www.jivesoftware.org/spark/Spark[/url]?

Thanks,

Ryan

I already tried Spark, Exodus and Gush, and everytime the Console of Wildfire presents the same error.

With Exodus the exodus program show´s this message:

The SSL certificate received from the server has errors.

Certificate does not match host: /C=US/ST=OR/L=Portland/O=Jive Software/OU=XMPP/CN=John Doe

Certificate fingerprint:

Thank you

Hi Rafael,

It looks like you’'re attempting to use the fake certification that comes with Wildfire. You will probably want to delete that certificate via the Admin Console and create a new one by following the url=http://www.jivesoftware.org/builds/wildfire/docs/latest/documentation/ssl-gu ide.htmlSSL Guide[/url].

Regards,

Ryan

Thank you!