powered by Jive Software

Login failed: make sure your username and password are correct and that you're an admin or moderator

I’m trying to login as admin and getting following message:

Login failed: make sure your username and password are correct and that you’re an admin or moderator.

/opt/openfire/logs/all.log:

2017.04.21 17:33:41 WARN [Jetty-QTP-AdminConsole-29]: org.jivesoftware.admin.LoginLimitManager - Failed admin console login attempt by admin from X.X.X.X

My environment:

rpm -q openfire

openfire-4.1.3-1.noarch

cat /etc/redhat-release

Red Hat Enterprise Linux Server release 6.8 (Santiago)

uname -a

Linux X 2.6.32-642.15.1.el6.i686 #1 SMP Mon Feb 20 02:29:10 EST 2017 i686 i686 i386 GNU/Linux

I remember password as I wrote it down, however I even tried to reset my password, still unable to login(

mysql> UPDATE ofUser SET plainPassword=‘X’, encryptedPassword=NULL WHERE username=‘admin’;\G

Query OK, 0 rows affected (0.00 sec)

Rows matched: 1 Changed: 0 Warnings: 0

ERROR:

No query specified

mysql>

Please advise.

Thanks in advance!

I also tried to change:

true

to false value inside of /opt/openfire/conf/openfire.xml followed by restarted of openfire service, yet while I was going through setup steps, in order to change admin’s password I had to specified current admin password (which I don’t know)

Please advise.

Thanks in advance!

I was able to do it by adding following:

my.user.name

right after and before inside of openfire.xml and followed by restart of openfire and then I was able to login to adminConsole

Are you sure, that you started the server with admin permissions?

I’m not sure what you mean by that…

Afaik OpenFire should be started with root permissions (at least on windows) in order to allow logins from the admin account.

I’m using systemctl script that being shipped with openfire (not using Winblowz).

slightly off topic, you’d need root/admin only if you’re trying to bind to port <1024, openfire adminconsole binds to port 9090

Paul is not exactly correct. You don’t have to run it as root. Just the user you are running it with have to has full permission to Openfire dir and its content. As for the Windows problem, it is UAC related and running as admin is not required when using service or installing not into Program files.