powered by Jive Software

Login identification

Before I install wildfire I was using an old version of JiveMessenger.

The login authentication was integrated with LDAP. There was an entry in DNS to identify the _xmpp-client of the domain ABC.COM.

So to login, it was enough to digit username@ABC.COM and the password.

Now, with the installation of wildfire, I have to login with username@SERVER.ABC.COM.

The login username@ABC.COM is not working.

what’'s the problem?

Oi Patrick,

What client are you using? When you log in you have to specify the correct user account. That means that if your server name is “myserver.com” then accounts need to be like for instance johndoe@myserver.com. If you use an account with a different server name then the server will try to route your IQ authentication request to a remote server. Therefore, you won’'t be able to log in.

However, some clients are smarter than others. Smart clients will let you specify any valid server name (even the IP address of the server) as your domain in your login account. Once a connection was established to the server using the specified domain they will switch and replace your specified account (with the incorrect domain) and use the real server name as discoverd from the server. Example of this smart clients are Spark and Exodus.

Then you may find configurable clients where you have to use your correct user account but you have a way to specify in the client that the connection has to be established to a given IP address or server name (that may differ from the domain of your user account).

And then you may find more rigid clients where you cannot specify an alternative server address to establish the connection. For this case you have 2 options: 1) request the client author to let you specify an alternative server address or 2) use the correct user account and make sure that your client machine can resolve the server name to point to the server.

Regards,

– Gato