powered by Jive Software

Login problem after installation

Hi community,

I installed openfire .deb on a debian machine.

The install process was fine, and after the setup wizard I can’t login. The site is only loading after click on Login and the browser is waiting for a response.

I tested with admin/admin and own password in the setup wizard.
I tested with internal DB and Postgres. Debian 10 and Debian 9.

Do you know about this issue?

Tank you.

What exact versions of Debian and Openfire (also Java)? I have tried 4.2.3 and 4.3.2 a few months ago on Debian 9.4.0 with OpenJDK 1.8.0 and it worked fine. You can also check the logs /usr/share/openfire. Look for all.log file.

Debian: 9.9 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u5 (2019-08-11) x86_64 GNU/Linux

openfire 4.4.1 and for a test the nightly build

OpenJDK Runtime Environment (build 1.8.0_222-8u222-b10-1~deb9u1-b10)

Log shows only this:
2019.09.01 20:53:16 INFO [pool-5-thread-1]: org.jivesoftware.openfire.spi.ConnectionListener[socket_s2s] - Started.
2019.09.01 20:53:16 WARN [pool-5-thread-1]: org.jivesoftware.openfire.spi.LegacyConnectionAcceptor - Configuration allows for up to 16 threads, although implementation is limited to exactly one.
2019.09.01 20:53:16 INFO [pool-5-thread-1]: org.jivesoftware.openfire.spi.ConnectionListener[socket_s2s-legacyMode] - Started.
2019.09.01 20:53:16 INFO [pool-5-thread-1]: org.jivesoftware.openfire.spi.ConnectionListener[component] - Started.
2019.09.01 20:53:16 INFO [pool-5-thread-1]: org.jivesoftware.openfire.spi.ConnectionListener[component-legacyMode] - Started.
2019.09.01 20:53:16 INFO [pool-5-thread-1]: org.jivesoftware.openfire.spi.ConnectionListener[connection_manager] - Started.
2019.09.01 20:53:16 INFO [pool-5-thread-1]: org.jivesoftware.openfire.spi.ConnectionListener[connection_manager-legacyMode] - Started.
2019.09.01 20:53:16 INFO [pool-5-thread-1]: org.jivesoftware.openfire.spi.EncryptionArtifactFactory - Creating new SslContextFactory instance
2019.09.01 20:53:16 INFO [pool-5-thread-1]: org.jivesoftware.openfire.http.HttpSessionManager - Starting instance
2019.09.01 20:53:16 INFO [pool-5-thread-1]: org.jivesoftware.openfire.http.HttpBindManager - HTTP bind service started
2019.09.01 20:53:36 INFO [Jetty-QTP-AdminConsole-26]: org.jivesoftware.util.cache.CacheFactory - Created cache [org.jivesoftware.util.cache.DefaultLocalCacheStrategy] for Locked Out Accounts

No new lines in the all.log with login attempts.

I have just installed fresh Debian 9.9 amd64 in VirtualBox (from Xfce-CD1 iso). Downloaded Openfire 4.4.1 deb installer. Ran it with su in term. Worked fine, although complained about /var/lib/openfire not belonging to the user is being created. Haven’t see such error on Ubuntu or older Debian. Went to localhost:9090, completed the setup and logged in into Admin Console. Created a user and was able to login with Gajim from a host.

The logs you provided don’t say much. Maybe something else is running on this system which is interfering with Openfire. Stop (or uninstall) it and then check netstat -a. Maybe something else is already using 9090 port, although you wouldn’t get a login screen in that case i guess. Try another browser, incognito/private tab.