powered by Jive Software

Logs are not getting generated, Openfire4.5.1.tar.gz, ubuntu 16.04, java 8

Hello,
install Openfire on ubuntu 16.04 using tar.gz, java 8 OF-4.5.1
can’t see any log files and stderr.log shows:
ERROR StatusLogger No Log4j 2 configuration file found. Using default configuration (logging only errors to the console), or user programmatically provided configurations. Set system property ‘log4j2.debug’

tried installing Openfire multiple times, error says the log4j2.xml file is not present but the file is present in lib folder tried giving different permissions, no luck,
anyone can help with the right config?

This might be a problem with how you start Openfire, not how you install it. The scripts that are used to startup Openfire typically refer to the log4j2 configuration file (which lives in the lib directory). An example of this can be found in the shell script to start Openfire that is part of the source code. I’m thinking this argument is missing when you startup Openfire.

@guus
thanks, it worked:D
I was using openfire/bin/openfire start