powered by Jive Software

Losing connection to AD

I have been running openfire and spark version 3.9.3 since may, installed on my primary DC

it works great, most of the time, but at least once a week my users lose connection to the server, and I cannot login to the admin console

basically, it cannot connect to my AD users any longer, until I shutdown the server for a few minutes, then restart it

any idea why this is going on?

thank you,

John

I really wouldn’t suggest putting in on your Domain Controller; I’m guessing you have no choice.

If it’s only occuring once a week you may want to check a few items:

  1. Do you have auto-updates running?

  2. Weekly backups?

  3. Full Antovirus scan

  4. SQL backup (if you take it offline to do it.)

Basically, if it’s happening at the same time each week, you most likely have something scheduled. Check the task manager to see if anything is matching your time(s) of disconnect.

in openfire, what are you using to connect to the DC? hostname, localhost, ip or loopback ip? If youre using anything other than the loopback IP (127.0.0.1), change it and see if that resolves your issue.

why would you not put it on the DC? I currently do not have a choice, but will be adding a few more servers to the forest over the next few weeks, and could possibly use one of the fileservers, if need be

where are you suggesting I use the loopback Ip?

also, this problem has gotten worse as more users are getting on it, it is now dropping connection to the AD user list about once every few hours, does that narrow the problem down at all?

if your openfire server is running on your dc as you have stated,

then use 127.0.0.1 for your LDAP host.

You can change this server settings

or in system proproties under ldap.host

after changing this setting, now I cannot login at all to the admin console, or on any of my clients through spark

is there a default admin password to get back in and change this back?

To get yourself back on track you can do:

  1. If using MS SQL as your DB, edit the settings in there manually and change the IP adress back

or

  1. Edit openfire.xml and change true to false - startup the application and run through the setup screens.

About the dropped connections: Do you have the Windows firewall turned on? If so, turn it off on all three options to rule that out… even if you think you have created the proper rules.