powered by Jive Software

Lost connection to LDAP server after server reboot


#1

Hi, all. I just installed Openfire 4.3.2 and connected it to an active directory server. But after a reboot of the host server, Openfire lost connection to the AD server. I had to change the setup value to false to reconfigure the LDAP settings. Can anyone help? I really appreciate it.


#2

What OS, how and where did you install and run Openfire?


#3

It is Windows server 2016. I installed it using the installation file and followed the wizard. It is installed in the default path/ C drive. I completed the configuration using the web interface after installation. Everything works after that. But every time after a server reboot Openfire cannot connect to AD anymore. I have tried to uninstall and re-install openfire multiple times and this happened every time.


#4

By default path you mean into Program files or just into C:\Openfire? How do you run Openfire? Via service or launcher? If you installed it into Program files and use it with the launcher, you must run it via Run as admin.


#5

make sure you are not running multiple instances by mistake. did you pick the embedded db or are you using an external one like ms sql? the settings are save in the db, so its possible there is a lock preventing the writing/updating.


#6

It is in program files and I just tried to run it as admin but the issue persists.


#7

Thanks! I am using MS SQL. I created a new SQL database and everything works fine now.