powered by Jive Software

Main Website Crashes When I Start Openfire Service on Centos 6

I recently installed Openfire 4.3.2 on my Centos 6 Linux box. I have also installed JAVA openjdk v1.8.0_212-b04.

Running “java -version” returns
openjdk version “1.8.0_212”
OpenJDK Runtime Environment (build 1.8.0_212-b04)
OpenJDK 64-Bit Server VM (build 25.212-b04, mixed mode)

When I run “rpm -qa | grep openfire”, I get
openfire-4.3.2-1.x86_64

When I start the openfire service with “/etc/init.d/openfire start”, I get the following:
Starting openfire:

When I stop the openfire service with “/etc/init.d/openfire stop”, I get the following:
Stopping openfire: [ OK ]

Note that the [ OK ] does not show when I start the openfire service.

After the service is started, I can access the Admin console on localhost:9090 and make all configurations OK. I can also connect the clients running Spark 2.8.3 to the Server when the Openfire service is running.

The problem is that as soon as I start the openfire service, my main website (hosted on the same Centos 6 Linux box, starts throwing Error 500.

Anyone else encountering this issue?

So, have you searched what error 500 means in your website software (that you haven’t mentioned)? Maybe your website service is also using same port as Openfire. You can either change Openfire ports or your web service ports.

I advise you to review the log files of whatever software is running your website.

Thanks guys. I reviewed the logs of my Apache server and discovered there was a shortage of memory to run processes. I have increased the memory RLimits for my Apache server and so far, both the Openfire installation and my websites are running ok.