powered by Jive Software

Messenger install bombs out

Matt/Bruce/et al;

During the install of Messenger 1.0.1 the install (performed through Add/Remove Programs as required on a Terminal Server) bombs out with the following:

java.lang.StringIndexOutOfBoundsException: String index out of range: -103

at java.lang.String.substring(Unknown Source)

at java.lang.String.substring(Unknown Source)

at ZeroGlh.a(Unknown Source)

at com.zerog.ia.installer.util.magicfolders.JavaHomeMF.a(Unknown Source)

at com.zerog.ia.installer.util.magicfolders.JavaHomeMF.b(Unknown Source)

at com.zerog.ia.installer.util.magicfolders.MagicFolder.initializeAllMagicFolderPa ths(Unknown Source)

at com.zerog.ia.installer.Main.d(Unknown Source)

at com.zerog.ia.installer.Main.c(Unknown Source)

at com.zerog.ia.installer.Main.main(Unknown Source)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.zerog.lax.LAX.launch(Unknown Source)

at com.zerog.lax.LAX.main(Unknown Source)

Environment:

WinServer2003 Standard

AD,DNS,DHCP,WINS,TS,SMS,SUS services running.

J2EE 1.4

J2SDK 1.4.2

Tomcat 4.1.27

I would be eternally grateful if you fine folks can help me on this and perhaps allow me to remain blissfully ignorant of java. Or am I just dreaming on that? I mean really, if I have to store anything else in my brain it is going to get too big to fit through a standard doorway.

–Jim Thompson

–The Manic Mechanic

Correction: Messenger Version is current: 1.0.6.

Hi,

Our installer doesn’‘t currently support WinServer 2003, hence the choking. We’‘ll try to update our installer to support WinServer 2003 as soon as possible. Someone will post the announcement of the new micro release here. I’'m very hopefull we can have something out by the end of the week if not sooner.

Sorry for the inconvenience.

-iain

Any progress being made on this installer issue? I really need to know if Messenger will be useable in my environment or will I need to go shopping for another IM product?

Hi,

Sorry for the delay. It took a little longer than expected to get the updated install software (it ended up being a paid upgrade) and there were some changes we have to make. We should have it done and on our site sometime this weekend.

Thanks for your patience.

-iain

Iain–

I just checked and the Messenger release still shows as 1.0.6. I take it you guys are still finalizing the install code. Let me know when it is ready.

–Jim T.

Jim,

We decided to keep the version number the same but make a new build that works on win2003. So, give the new build a shot - you can get the win builds from the downloads page.

Cheers,

–Bill