powered by Jive Software

Migrate Openfire 4.1.4 to 4.2.3 using same database

Good day, can someone help me?

I work with Openfire 4.1.4 and I intend to migrate to version 4.2.3, when doing the update I have no problem I made the link to my database without problem, my problem is that when I log in the client spark does not recognize the users that I have added as friends, the client shows me as disconnected even if they are active in their corresponding equipment, so that I show them in their current state I must add them again, is there any way to not add them back to my friends?

The database is SQLServer 2008, make a full copy and mount it on a test server, the connection between the server, the client (spark 2.8.3) and the database are satisfactory.

I forgot to mention that the server is Windows Server 2012 R2.

There shouldn’t be such problems when updating to new version. But maybe you can describe with more details how exactly you did your update. Were you installing new version on a new server as a fresh install? Maybe you have specified different server name at that point. That would explain why your old contacts doesn’t work, if the server’s name has changed.

If so, I clarify my situation.

1- Currently in my work I am operating Openfire 4.1.4 in Windows Server 2012 R2 and with Spark as a client, derived from random disconnection problems we have decided to update to the latest version of Openfire (4.2.3), at this moment all my users they have added the N contacts with which they communicate, as well as the groups that they have created in the Spark clients, the database I have in SQL Server 2008 and I have made a full backup of it.

2- Prepare a test environment with a server with Windows Server 2012 R2 OS and install Openfire 4.2.3, load the same plugins that my productive server has, link the backup of the database, until there I have no problem.

3- Start session in my Spark client pointing to the test server, when making the connection the contacts added to my client appear in gray as if they were offline even though they are online and when sending messages they never reach their destination , to be able to specify the sending of the messages it is necessary that I return to add my contacts.

contactos

NOTE: I want to avoid that every user has to return to add all their contacts since they are a considerable amount, my users are approximately 400.

Is there a way that these changes are transparent for my users and that they do not have to add back to each of their contacts?

During your second step when you have installed new Openfire, did you provide the same server name as in the old one? Server name is shown on the first page of Admin Console (XMPP Domain Name value). Although this should still be stored in the database you have linked to, but maybe new name was first stored in the openfire.xml file and then imported into database once you connected it.

Also, do you login in Spark using server’s IP name instead of XMPP Domain name?

The name of the server is different, the productive server is “openf1” and the test server is “opents1”.

Given that the problem lies in the names of the servers, there is a way to change the name of the server directly in the database to start up my test server as productive.

Or rather, is there an alternative method to make my test server productive or any method that you suggest?

Can you just repeat with a fresh install and using the correct name? Unless you already been using new server for a while and don’t want to lose new users, etc. Then you can stop the test server, go to its installation folder, conf folder, edit openfire.xml and change the last tag to false. Save it and run Openfire again. Go to admin console and repeat the setup process this time setting the right name, connect to the same database. It won’t overwrite your database (but do backup first) and your users should have usernames with old server name after that. Assuming it should fix your Spark problem.

ok, I’ll do the test and tell you what the result was.

Btw, the last tag is called setup. I typed it with brackets and these forums removed it…