powered by Jive Software

Miranda IM and OpenFire

Hi,

I got 2 questions about using Miranda IM v0.10.15.0 with OpenFire v3.8.2 on Win 7 SP1 x86.

The first is why I can only connect to the server without using SSL/TLS (Public XMPP Network)? For that matter, InstantBird also can’t connect, whining SSL handshake error. Only Spark could connect flawlessly even if I set OpenFire to require only encrypted connection (Miranda will whine “403 forbidden” with such setting for Public Network accounts; Secured Network accounts can’t connect regardless).

2nd question, I’ve set OpenFire to not accept new user registration, all Registration is done at server by admin. However I’ve set so that the user could change their password. Problem is how to change password using Miranda? Any other way to do it without the user using/installing other clients?

Thanks

  1. I am able to connect with Miranda to Openfire with TLS cheked. Same with Instantbird. Though i’m using self-signed certificates generated by Openfire (in Instantbird i had to go to

Tools > Options > Advanced > General, go to the config editor and set purple.ssl.check_certificates to false). Maybe Miranda is not liking something about your certificates.

  1. This is a question for Miranda developers.

Self-signed certificates? Did you mean the certificates auto-generated by Openfire at install, viewable at Server->Server Settings->Server Certificates and available from the 1st time Openfire ran, or did you generate them yourself?

Hmm, I tried your suggestion in changing the purple.ssl.check_certificates, but instabird is taking a mighty long time at “Connecting: initializing stream…”, and it still hasn’t connected by the time I write this post. Any ideas?

Self-signed means certificates not signed by some known authority (like Verisign), but generated and signed by a program itself, so it can’t be verified whether a certificate is valid and legitimate. Well self-signed are ok for internal and minimal use, they still let you encrypt the messages. So, yes, Openfire generates certificates and signs them itself on the first setup (though they can be regenerated at any point). I’m using those for many years and there was no problems with the clients other that them complaining, that it is a self-signed certificate and some clients requires disabling such checking (like Instabird, Jitsi, Gajim).

Thanks for explaining about self-signed certificates. However, I’ve disabled certificate checks per your suggestion, and still instabird won’t connect. It seems it enters an infinite loop at “initializing stream” phase. It also seem to enter such loop when I disable encrypted connection in Instabird’s account settings.

I wonder what’s goings on.