powered by Jive Software

Misc IM Gateway Questions - Pulled from comments in properties doc

says: in response to: jadestorm

Hey jadestorm,

Thanks for the fast reply, I didn’t expect you to answer so quickly =)

Ok, well it’s good to know I don’t have to actually edit gateway.jar itself.

I looked in the IM gateway documentation and it says, “This plugin is configured via the “Gateways” sidebar item located in the Openfire Admin Console. You can enable individual transports via the “Settings” sidebar item, and add new registrations/view existing registrations from the “Registrations” sidebar item”, which I assume is what you said in your comment as well ^^

The only problem is, I can’t see Gateway with Settings and Registrations section at the bottom of the admin console. I mean, I have found the System Properties page, with several properties such as cache.GatewayRegistrationCache.min and cache.GatewaySessionLocationCache.type, but there’s no Gateway section anywhere in the admin.

I’ve added the IM Gateway’s properties for Openfire to communicate with MSN (copy and pasted the property name and value from here to Add new property in the System Properties page) but I can’t add contacts from my Jabber client (Exodus).

I’ve become bald from scratching my head so much, will appreciate your response!

Hey jadestorm, Thanks for the fast reply, I didn’t expect you to answer so quickly =) Ok, well it’s good to know I don’t have to actually edit gateway.jar itself. I looked in the IM gateway documentation and it says, “This plugin is configured via the “Gateways” sidebar item located in the Openfire Admin Console. You can enable individual transports via the “Settings” sidebar item, and add new registrations/view existing registrations from the “Registrations” sidebar item”, which I assume is what you said in your comment as well ^^ The only problem is, I can’t see Gateway with Settings and Registrations section at the bottom of the admin console. I mean, I have found the System Properties page, with several properties such as cache.GatewayRegistrationCache.min and cache.GatewaySessionLocationCache.type, but there’s no Gateway section anywhere in the admin. I’ve added the IM Gateway’s properties for Openfire to communicate with MSN (copy and pasted the property name and value from here to Add new property in the System Properties page) but I can’t add contacts from my Jabber client (Exodus). I’ve become bald from scratching my head so much, will appreciate your response!

Dec 20, 2007 3:28 PM Reply Edit Delete Click to view OFnoob’s profile OFnoob says: in response to: OFnoob

Does the Gateway section not appear because I am not using Enterprise edition of Openfire?

Does the Gateway section not appear because I am not using Enterprise edition of Openfire?

Dec 20, 2007 3:47 PM Reply Edit Delete Click to view OFnoob’s profile OFnoob says: in response to: jadestorm

In the “server” tab of the Openfire admin console, the only sub-tabs that I can see that have the word “settings” are Email, Profile, Security, Compression, File Transfer, and STUN Settings…no Gateway Settings.

In the “server” tab of the Openfire admin console, the only sub-tabs that I can see that have the word “settings” are Email, Profile, Security, Compression, File Transfer, and STUN Settings…no Gateway Settings.

Dec 20, 2007 4:45 PM Reply Edit Delete Click to view OFnoob’s profile OFnoob says: in response to: OFnoob

Just one more thing, I remembered that OpenFire has lately been throwing a constant error:

Found old database version 5 for gateway…upgrading to version 6.

gateway - Database update failed. Please manually upgrade your database.

Does this mean because the MySQL version is not up to date, it is messing up the admin console, causing the Gateway Tab not to show up? I’m not sure because the error seems vague (unfamiliar with these terms)…

The gateway plugin should indeed appear with the enterprise plugin … or rather the enterprise plugin doesn’t prevent it from appearing. I’m most concerned about that MySQL error you are seeing. You should see somewhere (probably the error log?) what the actual database update error is. The 5 -> 6 upgrade isn’t doing a lot, so it’s odd that it’s triggering this. What version of MySQL are you using?

I am running Wamp Server 2.0 which uses MySQL version 5.0.45…

After reinstalling both Wamp and Openfire, the gateway tab appeared =)

I enabled the MSN gateway, and added a new registration for my Jabber user. Unfortunately it doesn’t seem to be fully working…I have MSN messenger signed in, and when I log in using the MSN transport via Jabber client, I am signed out of MSN Messenger. In the admin console, the gateway registration status icon for MSN gateway changes from grayed butterfly to a colorful one. On the other hand, the MSN transport does not change status on the Jabber client, nor can I add anyone or have anyone on MSN see me as online.

Another strange event I have is that whenever I reset the Openfire server, the user client passwords always reset…