powered by Jive Software

Moderation issues

As long as this bug is not fixed https://community.jivesoftware.com/casethread/381746
I’m resigning from moderation here. It is just too much to get spammed with emails and then having to go to every approved thread and unfollow… As moderation is tied to Key Contributors (what? o_0) i have removed myself from Key Contributors group.

Totally understandable, this forum is an awful user experience. Thanks for your work wroot!

I have no idea about this bug - I disabled email notifications long ago as Jive does display the relevant updates in the configured streams - it’s much more user friendly than emails. I also never need to un-follow an approved thread.

It’s a new issue (4-5 days old) since the recent JiveX upgrade, when the side menu disappeared from the home page and it started showing big “@” in the notification widget (another weird design choice, yeah i get it, it’s an INBOX, hehe). You can try approving a new thread now (to have more approvals, temporarily enable moderation based on points and set it to 5). For me it goes into JiveX Inbox and it says “wroot asked”, then this is not my thread and i wasn’t asking anything. Even not related to emails, it is a bug. Also, uncheck Unread only, as it for some reason automatically marked as read. Then you can go to such thread and check if Inbox is checked in the Follow menu. If it is not happening to you, and only to me, and even if it is happening to me because i have Email Watches stream enabled for my needs, this is still weird and a bug in my book.

I have already explained in the JiveX update thread why i prefer email to JiveX notifications or activity stream.

It happened to me with How to set up SSL/TSL to connect to server? - It is in my activity stream and I was following it. The author is fixed now.

Other moderated threads didn’t cause this issue, anyhow I didn’t approve so much. I’ll check if it happens again.

For me it still shows “wroot asked” in the Inbox list, but if you click on such entry, in the details pane it shows “correct_author asked”.

The problem is that Jive can’t reproduce this on a clean JiveX install. Hoping it will happen to some major client who went through many upgrades since Jive SBS like we did…

Mmm, after clicking on moderation one can simply click on “inbox” and there on “Hide new activity” for all questions which are shown as “/me asked …”.

In any case it’s really annoying but one does not have to open the thread.

As Guus has resolved with Jive an error being shown on the Spam Prevention Service page https://community.jivesoftware.com/casethread/389437

we might want to give this service a try.

Guus, all the options that Tim listed are already known and give no impact (other than IP bans, but one has to have an access to the logs and understand them - LG does). If you’ll get access to the Best Practices document, maybe you will find more options there.

But for now i want to try this Service. I will add myself back to the moderators group. Will also remove a requirement for a user to have 5 points to be able to post without moderation, to see how this service handles spam.

1 Like

Welcome back wroot

I’ve enabled the Mollom-based spam service. Details are in your mail (assuming that you’re under admin@ignite?)

No, i’m not, i guess.

I have already seen this page and checked the settings. Some are not very clear (just the name and Enabled). Will see how it goes.

Finally - mollom for cloud users. As we are in the cloud reading access-logs to figure out IP addresses is no longer possible for me.

Hm. Wonder how Daryl was going to find IP address for that request then.

database stores it

Attached to this message is the Best Practices for Spam Management (version 7) from Jive.
DOC-150765.pdf (1235804 Bytes)

Nothing really new in it. Message Governor is now disabled (value “0”). As it was annoying me with that “wait xx before posting again”. I can be really quick in the forums… Then again, spammers can see the warning and adjust their scripts for the timeout.

So far it looks like we have the same amount of manual moderation. It practically adds every new message to the queue, even if it is only a simple text. Or does it have to learn based on our approvals?

I was under the impression that this is the intended behavior of the functionality.

As I understand the system: None of the functionality provided by SBS will automatically disapprove a message. Instead, it tries to detect spam, and add those messages to the moderation queue for manual processing (a living person is always the last one to have final judgement).

The challenge for us is to configure the system in a way that only spam messages are added to the moderation queue (and non-spam messages should not end up in the moderation queue). This way, we’ll only periodically need to verify that all messages in the moderation queue are indeed spam messages, and bulk-reject them in one go. Kind of how your email client works with spam.

How many posts have you approved/rejected for the last 24 hours? I would say i did 7-8 of them (1 spam rejected, although another copy of the same spam message went through without moderation). Looking at the latest updated threads it looks like the most of the recent activity. As i said i have disabled points requirement. So now every new user is free to post without moderation (based on the previous configuration without using this service). As well as spammers are free to post. Only posts with links in them get moderated (if old configuration still takes precedent). So i assume that currently only the Spam Prevention Service is moving threads to the queue (ones with just text). It is on the normal setting. And i would say it does a bad job so far. Too many false positives. I don’t see any way to tune this behavior other than setting the relaxed mode of checking, which may let slip through more spam messages. Well, we can try this and check if it at least let through more normal messages.

Guus, i’m sorry if it sounds like nagging you Thanks for taking care and filing the ticket with Jive to make this service work. It is an intended behavior, but i was hoping it would analyze messages better and not put so many normal messages into moderation.

I wonder if timeout setting is not too low. Maybe it timeouts and then puts every message into moderation. There could be a button to test a connection…

Also suspicious user setting maybe working not in our favor. Most of the users posting questions here are new, so all of them will be suspicious. Of course in case of spam it is the same, a bunch of users are created and spam is posted (usually the same day as accounts created, though in the past we’ve seen lurking accounts). Maybe we should try disabling this setting, or lower it to say 1-2 hours. So if a user gets a reply and posts another message 5 hours later it won’t be suspicious anymore.

2015.09.15 set it to Relaxed mode for a try.