powered by Jive Software

MOTD does not work in spark client

Dear all,

I have just installed the below on centos 8.4 64 Bit

Openfire 4.6.3, build 9b35e20

and using Windows Spark client–t Spark 2.9.4 Ignite Realtime

But i faced 2 issues as of now

I have set MotD but when any user logs in no message appears.
I have checked enable message of the day box …

Also if the user is offline and I send a file to him i see a message stating the the file will be sent to the user when he logs in but after the user logs in . no message appears to him neither the file is sent to him.

Is there any specific setting on the server i need to do for the above functionality

Thanks and Regards

simon

Dear All,

I just installed pidgeon client and check it out.
It works fine here in pidgeon client
I do like spark client cause its rich interface

Hi
I can send a file to a offline user and he will see this file. But if this does not work for you, then you can transfer files via HttpFileUpload (paper clip to the right of the smiles)
Screenshot_56

Also, you must have the plugin installed on the server Openfire.

MOTD unfortunately does not work in Spark 2.9.X and unreleased Spark 3.0.0
https://igniterealtime.atlassian.net/browse/SPARK-2218

But at the moment Spark has no regular programmers, but we welcome fixes.

1 Like

Dear |Petrakova

Appreciate your reply and sorry for the delay.
I had the http file upload pluggin but i do face a problem
some times I get a error message which I have attached in the pic and sometimes nothing happens.
I have the enabled http bind settings under server settings and also enabled the pluggin
Also i am able to telnet to port 7070

appreciate
Capture1


your advice and help

regards

simon

Do you have any certificate installed in Openfire? I see that httpUpload uses https and if you do not have a certificate then you can only enable http - HTTP File Upload Plugin Readme

Also try to enable File Transfer Proxy, and try to transfer the file through the “up arrow” icon

Dear |Petrakova
Thank you for the quick reply actually I checked the spark logs and found the issue
my domain name and XMPP Domain Name was different
Its working now
but I have a issue
which file do i need for infinite size
i check the pluggin directory but no file avlibable when i can enter as mentioned in the pluggin readme file

thanks and apprecite

simon

sorry for my earlier mail
I mean which file in need to edit in the file upload pluggin for unlimited size

thanks and apprecite

simon

If you are using File Transfer then there is no file size limit.
If you use HttpUpload then files are saved to the Openfire server, file limit = server memory size.

Thank you for your quick reply .
yes the query about file size is for HttpUpload pluggin
as the read me says .

To configure the maximum allowable file size to be uploaded by clients, the property plugin.httpfileupload.maxFileSize can be set to a value in bytes.
If not set, a default value is used. To disable the file size limitation, set this property to a value of -1

so was just wondering
My server has 12 Gb
but even if i try to upload a 130 mb file it gives me the below error

XMPP error reply received from httpfileupload.openfire.baladia.gov.kw: XMPPError: not-acceptable - modify [File too large. Maximum file size is 52428800 bytes.

small files it works fine

apprecite your kind help

regards

simon

You are correct, by default the file size should not exceed 50 MB.
I think it’s right.

Yes ur right but since on the readme it says you can disable the file size just wondering where the option
which says in the readme

set this property to a value of -1.

regards

simon

I think this setting should be added and after adding, restart the server.

Dear Petrakova,

Thank you so much and really appreciate.
I was trying to figure out actually which file I need to enter the file upload size parameters and since first time working on openfire was actually unaware that it had to be in system properties

Once I did it it worked with no issues

Thanks and really appreciate for your great support

God Bless U

thanks and Regards

simon