powered by Jive Software

Moved installation, old database, but not seeing users in UI

I configured openfire to use a mysql instance for storing all of its data. It worked fine. I then moved the openfire installation to another machine and started up openfire. All worked fine as well. However, and here is where things become odd. If I use the admin UI the users I created are there, but they are not listed. If I search for the users the UI will return the properties of the user, which I can modify and updated without problems.

At the following URL is the snapshot of the missing users in the list. Notice how the UI says that there are 6 users, but does not display them. Also notice in the snapshot that I am using the latest edition of openfire.

http://www.timegeist.li:8000/f/7d8c9b26e5/

Are the old and new systems using the same version of Openfire? If not, do you have the same problem on the new system if you use the same version of OF as the old one?

What version is the old system?

Here is the interesting bit. I copied the files from one machine to the other. I tend to install things using a directory installation, so that I can copy from machine to machine without problems. Thus the old install and new install are completely identical.

Hello christian,

if you have user on old machine kindly take mysql backup first (dont copy mysql folder )

command is below :

stop openfire when you run this task

mysqldump -u root -p -h localhost databasesname > mysqlbackup.sql

than copy that mysqlbackup.sql to new machine and restore command is below

mysql -u root -p -h localhost databasename < mysqlbackup.sql