powered by Jive Software

Moving OpenFire to New Hardware

I’m going to migrate my OpenFire server from Windows 2003 server to Ubuntu.

I found this tutorial for migrate from Wildfire to OpenFire

http://wiki.igniterealtime.org/display/WILDFIRE/WildfiretoOpenfireUpgradeGuide

Does this manual apply for my idea also?

Greetings,

Well, it doesnt really apply to you. What DB do you use? Maybe you only have to backup your db. Then install fresh version on Ubuntu and replace the db with your backup. If you’re using external db, you won’t need to backup anything at all. Also, you can backup your /conf/openfire.xml file. But if you are not doing much customization to it, this is not a problem to make the setup process again. It won’t hurt.

Thank you very much, i have an embedded database.

I tried to copy the embbed-db folder to the new server but it seems that i lost my user, i have 300 user’s it could be impossible try to migrate manually.

Thank you

You shouldnt lose users. On a fresh install replace embedded-db folder with your backup, then edit /conf/openfire.xml and in the bottom change and then login to Admin Console and run setup selecting Embedded-db as your DB.

Your backup could be broken though. Have you made a copy after stopping your old server? While running it could be not complete DB.

Thank you wroot! Yeah you’re right, i had a problem with the files, since i made a backup without stop the server. It was solucionated… but i have another problem:

Since i move from Windows server to Ubuntu i can chek that in my server profile, i have many information of the old server: old name server, old path (i can check many phats with C:\Program Files, etc)

How can i solucionate this?

Thank you

I dont understand. Where are you seeing those old paths? There shouldnt be anything left while copying only the database. Have you made a clean install in linux?

Thank you again

I can see this old paths on my Administration Console. On the property “Server Name” i can see the old name server, on many properties i can see references to “C:\OpenFire”

By another hand, It was a clean installation, my steps to install:

  1. Install Ubuntu

  2. Install Open Fire

  3. Stop service Open Fire in Windows 2003 server

  4. Copy the embbed db.

  5. Send this copy to Ubuntu 8.04

  6. Enter to http://server:9090 and ask the questions.

Greetings,

1 Like

I can’t find these paths in my embedded-db file. So, i can’t help without the developers insight here. Are these paths making some issues to your server?

For example:

In fastpath i can check: @workgroup.oldnameserver.domain.com

In spark when i try to find an user it says that can’t connect to search service (i think that it’s trying to reach the service with name of the old server)

When i try to add a user with spark the name of user is : user@oldnameserver.domain.com

Thank you

Don’t know. I havent seen such problems after moving from Wildfire to Openfire, though the path were changed. Try changing Server Name and Search service name in Admin Console.

Thank you.

But, i can’t find where ihave to change the search service

Can u help me?

Greetings.

Did you edit your openfire.xml to read <setup>false</setup>, the server must be stopped to do this. Then go to the web administration site and step through the setup again. On the second screen make sure you enter the new domain name for the server. Once you are done with the setup make sure any incorrect certificates are removed. Also sheck the openfire system property xmpp.domain to make sure it is correct. You can also edit the settings on the main screen if the server name is still not right. Any manually added lines in the openfire.xml file referencing windows paths will need to be manually changed to their new paths.

miguelalbores wrote:

But, i can’t find where ihave to change the search service

Server Settings > Search Service Properties

if he changed the name of the chat server to a different name and the users are stored locally then aren’t their JID stored in the database. If that is the case he will need to edit the database to fix the users. I may be wrong though.

Well, there are indeed a lot of entries in db with server name, whether users’ JIDs or else. Maybe that should be replaced manually. openfire.script i mean (embedded-db).

Dear wroot:

I can fix the problem. I upgrade to openfire 3.5.2, then i install search service plugin.

Thank you very much for your help.

I have the same issue. Did you install the DB or just install the Ubuntu and did embeeded transfer to Linux?