MS OCS 2007 R2 XMPP Gateway

Just read about this new free add-on to OCS 2007 R2. It apparently allows OCS 2007 R2 to federate with XMPP networks, such as Google Talk, Sametime and Jabber. Anyone had the chance to investigate it further, or better still try it out with Openfire? Early days I know…

MS XMPP works with Google Talk without any issues. Also like know if someone have some experiences MS XMPP<->Openfire. Any issues?

Hi guys,

I have tested because we plan to replace Openfire by OCS but we need to keep backward compatibility.

My OCS setup is able to talk to Google Talk, but not with Openfire…

I have tested TCP dialback and TLS. (Configuration is ok as the server is already doing S2S with some others Openfire, certs are ok, CA trusted bla bla…)

I’ve posted on OCS edge server forum and no one could help me :confused:

Are developpers still alive ? 3.6.4 is really a piece of shit in advanced(enterprise) configuration…(look at my other posts, look at the bug fix list for 3.6.5 and you’ll see I’m totally objective).

vinz wrote:

Are developpers still alive ?

Official JiveSoftware developers are not working on Openfire.

And that means there are NO support at all for Openfire. Great! I thought this would very interested topic to test and verify (Openfire<->OCS federation with OCS XMPP server). Not very promising I would say.

I didnt say noone is working on Openfire. There are some folks, but OCS is not their priority. And as i said on the other OCS related thread, i think MS developers are the ones who should make it compatible with other servers, not just with XCP and Gtalk.

I have to apologize about OCS and Openfire compatibility (as I said I have tested it).

This does not work, but I have also tried with Tigase, Jabberd14 and Ejabberd (only TCP dialback for those) and it does not work either. (but it works with gtalk so configuration is ok).

Seems to be an OCS issue.

Have you tryed the latest MS fix. -7FA0FAF80B82&displaylang=en

After I patched OCS with the hotfix, I only managed to get it to work one way, which is from Openfire to OCS and not the other way round. Openfire web admin showed it works for both incoming and outgoing to Google Talk but to OCS only outgoing.

Has anyone else had any success?

Checkout NextPlane Federation Server ( it offer IM, Presence, Multi-User Chat federation between OCS and Openfire. It is the only thing out there that really works.

Finally got it to work. The reason why incoming messages from OCS to Openfire failed is because of the security settings. Even though s2s security settings is set to optional, it will still try to negotiate an SSL session and the java SSL engine failed. Set TLS to unavailable, everything’s fine.

Anyone knows the solution to the SSL issues

LocalOutgoingServerSession: Handshake error while creating secured outgoing session to remote server: (DNS lookup: General SSLEngine problem


I set the s2s setting to no TLS but I still cant get the two to be friendly. This is the transcript of the messages:

XMPP gwy has ** **as the configured domain


<stream:stream xmlns:stream=“” xmlns=“jabber:server” xmlns:db=“jabber:server:dialback” from=“” to=“” id=“c0f6309c” version=“1.0” xml:lang=“en-US”><stream:stream xmlns:db=“jabber:server:dialback” xmlns:stream=“” xmlns=“jabber:server” from=“” id=“ac3631fa” version=“1.0”>stream:features</stream:features><db:res ult from=“” to=“”>899fcaf82c8034f3b6094f6621e19ea8625401d1</db:result ><db:result from=“” to=“” type=“valid”/>

<stream:stream xmlns:db=“jabber:server:dialback” xmlns:stream=“” xmlns=“jabber:server” to=“” version=“1.0”><stream:stream xmlns=‘jabber:server’ xmlns:db=‘jabber:server:dialback’ xmlns:stream=‘’ id=‘004a37f4’ version=‘1.0’>stream:featuresEXTERNALDIGEST-MD5</stream:features><db:result from=“” to=“”>c20f6727c19944d64b320c6ada14103ed7e402a0</db:result>< db:result from=“” to=“” type=“valid”>c20f6727c19944d64b320c6ada14103ed7e402a0</db:result>.

Appreciate any help

Have you tryed the latest fix? I noticed in some other article that this might fix the issue. Please share the results. 7b1-7fa0faf80b82