powered by Jive Software

MSN not working for some users

We are having problems with some users connecting to MSN. We have some users who can connect to MSN just fine, but others who can not.

I had the problem earlier, so I upgraded the Openfire server (Linux) from 3.3.0 to 3.3.3 and upgraded the gateway from 1.1.0 to 1.1.3a. That seemed to fix the problem.

But now the problem is back. I currently show one users connected to MSN. But at least two other users are not able to login. I deleted the MSN login and re-added, but that did not make a difference. Here is a Debug of one user trying to connect.

2007.11.01 07:59:27 Received iq packet: <iq id=“SHvwd-88” to=“msn.im.bankserv.com” type=“set” from="twells@im.bankserv.com/spark"><query xmlns=“jabber:iq:register”><username>todd.wells@bankserv.com</username><password>XXXXX</password><x xmlns=“jabber:iq:gateway:register”/></query></iq>

2007.11.01 07:59:27 msn: Sending packet: <presence type=“probe” to="twells@im.bankserv.com/spark" from=“msn.im.bankserv.com”/>

2007.11.01 07:59:27 Received presence packet: <presence type=“error” to=“msn.im.bankserv.comfrom="twells@im.bankserv.com/spark"><error code=“403” type=“auth”><forbidden xmlns=“urn:ietf:params:xml:ns:xmpp-stanzas”/></error></presence>

2007.11.01 07:59:27 msn: Sending packet: <iq type=“result” id=“SHvwd-88” from=“msn.im.bankserv.comto="twells@im.bankserv.com/spark"/>

2007.11.01 07:59:27 Received presence packet: <presence id=“SHvwd-7” to=“msn.im.bankserv.comfrom="twells@im.bankserv.com/spark"><status>Available</status><priority>1</priority& gt;</presence>

2007.11.01 07:59:27 A new session has come online: twells@im.bankserv.com/spark

2007.11.01 07:59:27 Created msn session for twells@im.bankserv.com/spark as ‘todd.wells@bankserv.com’

2007.11.01 07:59:27 Creating MSN session for todd.wells@bankserv.com

2007.11.01 07:59:27 Logging in to MSN session for todd.wells@bankserv.com

2007.11.01 07:59:27 session 445 established

2007.11.01 07:59:27 MSN: Session established for todd.wells@bankserv.com

2007.11.01 07:59:27 session 445 sent message VER 1 MSNP11 CVR0^M

2007.11.01 07:59:27 MSN: Session messageSent for todd.wells@bankserv.com : VER 1 MSNP11 CVR0^M

2007.11.01 07:59:27 session 445 sent message CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 8.1.0178 MSMSGS todd.wells@bankserv.com^M

2007.11.01 07:59:27 MSN: Session messageSent for todd.wells@bankserv.com : CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 8.1.0178 MSMSGS todd.wells@bankserv.com^M

2007.11.01 07:59:27 session 445 sent message USR 3 TWN I todd.wells@bankserv.com^M

2007.11.01 07:59:27 MSN: Session messageSent for todd.wells@bankserv.com : USR 3 TWN I todd.wells@bankserv.com^M

2007.11.01 07:59:27 session 445 received message VER 1 MSNP11 CVR0^M

2007.11.01 07:59:27 MSN: Session messageReceived for todd.wells@bankserv.com : VER 1 MSNP11 CVR0^M

2007.11.01 07:59:27 session 445 received message CVR 2 8.1.0178 8.1.0178 8.1.0178 http://msgruser.dlservice.microsoft.com/download/1/A/4/1A4FEB1A-18E0-423A-B898-F 697402E4F7F/Install_Messenger.exe http://get.live.com^M

2007.11.01 07:59:27 MSN: Session messageReceived for todd.wells@bankserv.com : CVR 2 8.1.0178 8.1.0178 8.1.0178 http://msgruser.dlservice.microsoft.com/download/1/A/4/1A4FEB1A-18E0-423A-B898-F 697402E4F7F/Install_Messenger.exe http://get.live.com^M

2007.11.01 07:59:27 session 445 received message XFR 3 NS 207.46.111.77:1863 0 65.54.239.20:1863^M

2007.11.01 07:59:27 session 445 closed

2007.11.01 07:59:27 MSN: Session closed for todd.wells@bankserv.com

2007.11.01 07:59:27 MSN: Session messageReceived for todd.wells@bankserv.com : XFR 3 NS 207.46.111.77:1863 0 65.54.239.20:1863^M

2007.11.01 07:59:27 session 446 established

2007.11.01 07:59:27 MSN: Session established for todd.wells@bankserv.com

2007.11.01 07:59:27 session 446 sent message VER 1 MSNP11 CVR0^M

2007.11.01 07:59:27 MSN: Session messageSent for todd.wells@bankserv.com : VER 1 MSNP11 CVR0^M

2007.11.01 07:59:27 session 446 sent message CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 8.1.0178 MSMSGS todd.wells@bankserv.com^M

2007.11.01 07:59:27 MSN: Session messageSent for todd.wells@bankserv.com : CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 8.1.0178 MSMSGS todd.wells@bankserv.com^M

2007.11.01 07:59:27 session 446 sent message USR 3 TWN I todd.wells@bankserv.com^M

2007.11.01 07:59:27 MSN: Session messageSent for todd.wells@bankserv.com : USR 3 TWN I todd.wells@bankserv.com^M

2007.11.01 07:59:29 Received iq packet: <iq id=“SHvwd-89” to=“msn.im.bankserv.com” type=“get” from="twells@im.bankserv.com/spark"><query xmlns=“http://jabber.org/protocol/disco#info”/></iq>

2007.11.01 07:59:29 msn: Sending packet: <iq type=“result” id=“SHvwd-89” from=“msn.im.bankserv.comto="twells@im.bankserv.com/spark"><query xmlns=“http://jabber.org/protocol/disco#info”><identity category=“gateway” type=“msn” name=“MSN Transport”/><feature var=“http://jabber.org/protocol/disco#info”/><feature var=“http://jabber.org/protocol/disco#items”/><feature var=“jabber:iq:gateway”/><feature var=“jabber:iq:register”/><feature var=“jabber:iq:version”/><feature var=“jabber:iq:registered”/></query></iq>

2007.11.01 07:59:30 Received presence packet: <presence id=“SHvwd-90” to=“msn.im.bankserv.comfrom="twells@im.bankserv.com/spark"/>

2007.11.01 07:59:30 An existing resource has changed status: twells@im.bankserv.com/spark

2007.11.01 07:59:43 session 446 timeout

2007.11.01 07:59:43 session 446 sent message PNG^M

2007.11.01 07:59:43 MSN: Session messageSent for sven@svenmead.com : PNG^M

2007.11.01 07:59:44 session 446 received message QNG 46^M

2007.11.01 07:59:44 MSN: Session messageReceived for sven@svenmead.com : QNG 46^M

2007.11.01 07:59:52 Received iq packet: <iq id=“SHvwd-91” to=“aim.im.bankserv.com” type=“get” from="twells@im.bankserv.com/spark"><query xmlns=“http://jabber.org/protocol/disco#info”/></iq>

2007.11.01 07:59:52 aim: Sending packet: <iq type=“result” id=“SHvwd-91” from=“aim.im.bankserv.comto="twells@im.bankserv.com/spark"><query xmlns=“http://jabber.org/protocol/disco#info”><identity category=“gateway” type=“aim” name=“AIM Transport”/><feature var=“http://jabber.org/protocol/disco#info”/><feature var=“http://jabber.org/protocol/disco#items”/><feature var=“jabber:iq:gateway”/><feature var=“jabber:iq:register”/><feature var=“jabber:iq:version”/></query></iq>

2007.11.01 07:59:55 Received iq packet: <iq id=“SHvwd-92” to=“msn.im.bankserv.com” type=“get” from="twells@im.bankserv.com/spark"><query xmlns=“http://jabber.org/protocol/disco#info”/></iq>

2007.11.01 07:59:55 msn: Sending packet: <iq type=“result” id=“SHvwd-92” from=“msn.im.bankserv.comto="twells@im.bankserv.com/spark"><query xmlns=“http://jabber.org/protocol/disco#info”><identity category=“gateway” type=“msn” name=“MSN Transport”/><feature var=“http://jabber.org/protocol/disco#info”/><feature var=“http://jabber.org/protocol/disco#items”/><feature var=“jabber:iq:gateway”/><feature var=“jabber:iq:register”/><feature var=“jabber:iq:version”/><feature var=“jabber:iq:registered”/></query></iq>

It “looks” like the MSN library isn’t able to connect via https to the authentication server it needs to talk to. Port 443. Is there any sort of proxy set up on your network that might be required to get through on port 443?

Note that I realize it doesn’t make a lot of sense that this only occurs for some users in that scenario, but it’s a starting point.

How can I determine where it it trying to connect via http? I do not see any https request in the logs.

Also, do you have any idea why is the plugin trying to download the Install_Messenger application?

http://msgruser.dlservice.microsoft.com/download/1/A/4/1A4FEB1A-18E0-423A-B898-F 697402E4F7F/Install_Messenger.exe

The https connection isn’t logged (currently). I probably should tweak it to be visible. But it’s a part of the MSN authentication process.

Ignore the line about the .exe. That’s not being downloaded. That line is telling you something along these lines (I don’t have the precise order in my head) …

  • what version you have

  • what the min version is

  • what the recommended version is

  • where to get a new version

(of MSN Live Messenger) It’s informational for the most part. (the only thing that matters is if the min version is higher than your current version)

Can you tell me what domain the failing https request would be going to so I can ask my Firewall admin if there are any packets being blocked? microsoft.com go.love.com, ???

login.live.com =)

(lol did you just say love and msn in the same thread?)

nexus.passport.com is also a possibility, but it shouldn’t be contacting that one in the current configuration.