powered by Jive Software

MUC Access

I’‘m using Smack 2 and Messenger 2.2.1 and am having an interesting problem with MUC. I log in to the Messenger server, which seems to go fine, but when I attempt to MultiUserChat.create I get ‘‘No response from server’’. I’‘ve attempted to extend the timeout to a few minutes but still the same response. I’'ve used MultiUserChat.isServiceEnabled but have goten a ‘‘false’’ back. I was under the impression that Messenger included a MUC. Is this true? I have the plain vanila version, nothing extra installed, no plugins.

I’'ve originally used XMPPConnection.createGroupChat which works fine but found suggestions in this forum that suggested that MultiUserChat was the way to go.

Any help would be very useful. Thanks - AYAL

Open up the debugger and post the packet trace. The should help to diagnose the problem

Sent[/b]

Received[/b]

I did notice one mistake I made which was using the username in the MultiUserChat.create instead of the rooms nickname. Fixed it but the results are the same.

Message was edited by:

aspitz

Ok, I was just really stupid. I didn’‘t realize the MUC work was documented as an extension. Once I found the documentation I was able to clear up what’'s supposed to go where.

Thanks - AYAL