powered by Jive Software

MUC available to other Servers

Hello,

I can’t find the setting so I decided to ask here.

How can I make the MUC (Groupchat) available to everyone. Also to users outside my Server?

I would be very happy if someone could help me :slight_smile:

You have to establish Server to Server connection with that remote server (check http://yourserver:9090/server2server-settings.jsp). Then the users from the other server should be able to browse your MUC service and join chats.

Service Activated - Remote Servers are allowed to connect [5269]

Inactive connections are closed after 10 Minutes.

Permit connection - everyone.

that is my configuratoin

Instant Messages are send correctly to other Servers

see http://www.igniterealtime.org/community/thread/37538?tstart=0.

In the DNS the whole domain is set to one domain (domain.tld, *.domain.tld).

I have now also set conf.domain.tld to the same IP-Address.

But I think that this is not solving the problem.

About two months ago I had the same problem, but after adding an DNS entry and waiting for the cache updates our server is reachable by other servers.

dig SRV _xmpp-server._tcp.conference.cs.uni-potsdam.de ; <<>> DiG 9.4.3-P2 <<>> SRV _xmpp-server._tcp.conference.cs.uni-potsdam.de
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18237
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0 ;; QUESTION SECTION:
;_xmpp-server._tcp.conference.cs.uni-potsdam.de.     IN SRV ;; ANSWER SECTION:
_xmpp-server._tcp.conference.cs.uni-potsdam.de.     43200 IN SRV 10 10 5269 lisa.cs.uni-potsdam.de.

Best regards

Yeah, that was the answer :slight_smile: thanks!