powered by Jive Software

MUC chat room - "Room Member" User Permissions problem

Hello,

I’m new to OpenFire and XMPP but already love it for my forums because of the performance over a PHP Ajax Chat solution. I understand that the MUC feature in Openfire is new and may still be buggy, however, I wanted to know if this issue I’m experiencing is a bug or I just don’t understand the setting.

I created a Private Chatroom in a MUC group chat conference service. The room is set to only permit approved members to join (no password). When users permissions are set to “Room Member”, they somewhat join the room (no restricted member exception), but are unable to see any chat messages or type any messages. They also can not see any users in the Member list. In the Openfire Admin Console, it also displays zero users in session in the room. WHen permissions are set to “Owner”, or “Room Admin”, everything works as it should but “Owners” can not see “Room Members” in the chat room.

Setting a password works fine, but it would be nice to not have one. I have not tried any other client yet (because they other clients don’t even login).

Is this a known issue, or am I screwing up somewhere. Should I try a new client (what would you recommend).

Openfire 3.6.4 on XP SP2 (installed JRE package)

SparkWeb Client

Also, what product is being used for the forums on this website. Is it a product of Jive SBS?

Thanks in advance for the help

Hi pender,

I understand that the MUC feature in Openfire is new and may still be buggy …

No, the Multi-User Chat component of Openfire was present in the oldest Wildfire 2.4.0 version I know. I know some issues with supporting multiple MUC components, but the “normal” support works fine for me.

I created a Private Chatroom in a MUC group chat conference service. The room is set to only permit approved members to join (no password). When users permissions are set to “Room Member”, they somewhat join the room (no restricted member exception), but are unable to see any chat messages or type any messages. They also can not see any users in the Member list. In the Openfire Admin Console, it also displays zero users in session in the room.

This maybe is a bug of SparkWeb, it works fine for me with Pidgin or Psi. If you don’t see the room occupants online in the admin console something is wrong and they aren’t really joined the room.

Can you provide more infos? Maybe a message log or do you see some errors or warnings in the openfire logs? I don’t know SparkWeb, I tried to test the online demo, but I can’t login. You can try to test it with another client?

Also, what product is being used for the forums on this website. Is it a product of Jive SBS?

The page footer look like this

There were no errors or exceptions generated in the logs (error or warning). I cleared the logs and reset the room settings and tried to connect to be sure that I did not overlook and error.

I tried the following clients without success.

  • Pidgin
  • Jeti
  • Meebo Web
  • Spark and SparkWeb
  • Psi
  • Adium and iChat

On the client, it gives an error message “not accepted” after failing to connect to the MUC room. Besides this issue, all clients work fine on regular IM and password protected MUC rooms.

I will try to uninstall and reinstall openfire and perhaps try another server just to test. Can someone recommend a server to try for Windows XP.

Hm, just an idea, did you setup your members with the bare JID? For example "user@domain.lt". Or did you set only “user” or "user@domain.lt/ressource"? It should be the bare JIDs of users.

If you start Pidgin via command line and “pidgin -d” it generates debug output. It would be nice to see what happens with your MUC room.

When managing the room’s User Permissions, I only entered the JID on the user without the domain. When it was added it shows up on the same page as user@domain. It does not display anything about the resource or MUC service for the registered users.

Try to setup your members with bare JIDs aka “user@domain.lt”. I added a screenshot of the admin console. A username without an domain isn’t a JID. Hmm, but if it shows bare JIDs, I’ve no more ideas, what goes wrong.

Right, before I was just entering an openfire username and not a JID. It still did not work, but thanks for all your suggestions and help.

I will try to reinstall tomorrrow to see if that makes a difference.