powered by Jive Software

MUC omemo works on only for some users

Hi,

I have recently tried private group chats and sometimes the thing works but in part, some people have omemo enc. some dont…an some people do get a windows to confirm omemo keys…and even if they do that the error in the client app is “error fetching omemo keys”.

I have setup Members only in the chat group settings…

I am using a vpn + ignite openfire.

Any ideas?

Any help would be greatly appreciated.

Cheers!

Another thing i noticed is that simetimes the group chat starts encrypted and then suddenly another test account looses enc.

Im really stuck with muc and omemo :sob:

The latest was that the creator of a private group chat is not omemo enc until it disables and then enables his account.

After enabling his account in the client app and entering the group chat he can type enc omemo again.

Anyone? :pleading_face:

which client are you using?

Hi,
I have tried snikket, conversations and blabber.

Same thing…

And btw in groups you can’t send pictures, videos, etc, is that normal?

Im really struggling to find a solution for this :sob::sweat_smile:

Unfortunately, I didn’t work with omemo. You can use the httpFileUpload plugin to share files in group chats.
https://www.igniterealtime.org/projects/openfire/plugins.jsp

I have tried to add the plugin, it only makes things worst, normal users cant send nothing on 1 on 1 chat. Sending files fails.

Autojoin to groups doesnt auto add peiole to it, only in public room creation it adds automatically but then it dies ot allow them ti write anything, they need to ask permission.

Thr owner cant make them become members only admins but cant revoke admin privilege from them at later point.

Strange things…

Is there a paid install support/check by ignite?

Cheers

Sure, look at this
https://www.igniterealtime.org/support/service_providers.jsp

1 Like

Thanks! :+1::slightly_smiling_face: