powered by Jive Software

MUC on a different server

Hi,

I have two servers (officeA and officeB) which are both running the same versions of wildfire (3.1.1). The clients can see users from the different servers respectively. However, I am having some issues when it comes to MUC. When user1@officeA wants to join a room on office2, he/she can not see a list of rooms availiable to them. The same can be said for user2@officeB.

All of the firewalls have been disabled and all ports are open. DNS entries have been added to whitelists as well.

Does anyone have any ideas on how to establish a connection to a room on a different server?

Waiting in anticapation.

Hi,

do you see errors in the log files?

It may or may not help to add DNS records for conference.officeA and conference.officeB.

LG

I’‘m having this same sort of issue. I have all security stuff disabled (ssl/tls s2s and s2c and dialback) because I want to look at traffic once I get everything working. and the s2s is set to enable on default port and allow any. I’‘m connected to officeA and want to join/create a new room on officeB. I’‘m using latest wildfire on both servers 3.2.3 and gaim client. In gaim I try to connect to s3@conference.officeB.blah.edu . I’‘m getting a 404 error back from officeA and this error in debug log of officeA java.lang.Exception: Failed to create connection to remote server. using nmap i verfied s2s and s2c ports are open on both servers. and running tcpdump on officeA it doesn’'t send ANY traffic to officeB when i try to connect to room. Any ideas?

Hey edify,

Could you enable the debug log in both servers and tell us what you see on each server?

Thanks,

– Gato

thank you for getting back to me,

the server I’'m signed into is basin and the username is test1… that debug log contains

2007.03.22 18:29:33 test1 authorized to test1

2007.03.22 18:29:54 Error sending packet to remote server:

java.lang.Exception: Failed to create connection to remote server

at org.jivesoftware.wildfire.server.OutgoingSessionPromise$PacketsProcessor.sendPa cket(OutgoingSessionPromise.java:212)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise$PacketsProcessor.run(Ou tgoingSessionPromise.java:184)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

2007.03.22 18:30:10 Ignoring extra content {}

the other debug log only contains

2007.03.22 18:29:13 Ignoring extra content {}

Message was edited by: edify

Hi,

it seems that the s2s connection fails. I’'m not sure if this is a problem with certificates or a network/routing/firewall problem.

On host “cse.lehigh.edu”:

Can you resolve “rcm2.cse.lehigh.edu” with command “host rcm2.cse.lehigh.edu” ?

Can you connect to “rcm2.cse.lehigh.edu:5269” with command “telnet rcm2.cse.lehigh.edu 5269” ? (you should see a connection established message)

LG

Hey edify,

That information is not the one I was expecting to see. Make sure that you have the debug log enabled in both servers, try using a room of the remote server (after debug is enabled) and make sure you are getting info from logs/debug.log file. You should find entries starting with OS -, AS -, etc.

Thanks,

– Gato

$ telnet rcm2.cse.lehigh.edu 5269

Trying 128.180.120.124…

Connected to rcm2.cse.lehigh.edu (128.180.120.124).

Escape character is ‘’^]’’.

hello

</stream:stream>Connection closed by foreign host.

i typed hello obviously…

that is the contents of /opt/wildfire/logs/debug.log … I’'m not sure what else you want…

I enabled debug by going to logs on the left in the web interface then selecting debug tab, then enable and save. Is there another way of enabling debug that gives more information?

I’‘ve also noticed that on rcm2 there is the following error on boot, not sure if it’‘s the cause since it doesn’'t seem basin is even trying to contact rcm2

2007.03.23 11:25:39

org.jivesoftware.wildfire.auth.UnauthorizedException

at org.jivesoftware.wildfire.auth.DefaultAuthProvider.authenticate(DefaultAuthProv ider.java:46)

at org.jivesoftware.wildfire.auth.AuthFactory.authenticate(AuthFactory.java:149)

at org.jivesoftware.wildfire.admin.login_jsp._jspService(login_jsp.java:135)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:491)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1074)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:39)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:65)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:69)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:98)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:365)

at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:185)

at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)

at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:689)

at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:391)

at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:146)

at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.Server.handle(Server.java:285)

at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:457)

at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:765 )

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:627)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:209)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:357)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:329)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:475)

thread bump.

is there any idea’'s on this problem?

also I’'ve noticed that this problem happens when trying to talk to users on another server, not just with MUC

alright turns out this is a case of shooting ones self in the foot.

I was trying to make things simpler, so I disabled all the server to server security. Apparently jabber doesn’'t like this, I turned server dial-back back on, on both ends and everything started to work again.