powered by Jive Software

MUC Problem with 2.1.0

Hey guys,

Great piece of software - can’'t wait for 2.1.0!

I’‘m testing out the 2.1.0 beta (Jan 7 build), and I’'m having a problem with MUC.

I can’‘t seem to view a list of rooms. I’‘m using Pandion - and this worked fine in 2.0.1. It just says there are no rooms. I can’'t even see persistent rooms I created from the either the client or admin interface.

I downgraded to 2.0.1 just to verify that I wasn’'t imagining anything, and it worked as expected.

Is this a Jive or Pandion issue?

Thanks for the bug report – we’'ll look into it and let you know what we find.

Regards,

Matt

Hey Huzio,

I tried to reproduce the problem using Pandion 2.1.1 and this is what I found.

  1. By default, Pandion sent a disco request to “conference.jabber.org” which is not my MUC service address. So make sure that your client has the correct MUC service address. You can use the Tools->Network traffic to check the sent and received packets.

  2. Trying to configure pandion to use the correct muc service address I went to Actions->Join a Conference room and clicked on “Other Service”. In that window I wrote “conference.localhost”. This time pandion sent a correct disco request and the server returned the list of rooms. Unfortunately, Pandion complained saying that there is an error in the script of the page.

I’‘m going to check with Sebastiaan (the Pandion developer) to see what’'s going on.

Regards,

  • Gato

Thanks for looking into this.

I actually realized it was trying to connect to jabber.org and configured it accordingly.

I checked the Pandion forum and found this post that looks similar http://forums.pandion.be/viewtopic.php?t=344.

That’'s why I was wondering if this was a Jive or Pandion issue.

The sooner I can get these two pieces to work together, the sooner I’'ll be able to do a pilot rollout.

Update on this issue:

  1. Sebastiaan is going to fix Pandion so that it uses the correct server name by default.

  2. We found a bug in the disco reply that Jive Messenger sends to MUC requests. We’'ll get this fixed which should resolve the problem with Pandion.

Thanks,

Matt

I seem to have the same problem with PSI.

Service Directory branches out to my chat server, but it won’‘t populate any persistant rooms. I however can “manually” join the chat room w/o a problem, it just won’‘t list. I don’‘t believe this is a problem with PSI only, although I have not tested it with Exodus, I did try Pandion, Eros or whatever it’'s called and JAJC.

Thanks for the additional info. We’'ll update this thread when a patch is in CVS. We may also release a Beta 2 before the final release on the 14th. There are a number of other important bug fixes that have been made over the past couple of days that it would be great to get feedback on as well.

Regards,

Matt

Update on this issue:

I was able to browse the list of group chat rooms using Pandion 2.1.2 beta and the latest code of messenger. You can try with the next nightly build or just wait for Beta 2 which will come out tomorrow night.

Regards,

– Gato

Did you try using Psi?

Yes. I tried with v0.9.3 and I was able to discover the muc service and existing muc rooms.

Let me know if you are running into any problem.

Thanks,

– Gato

I still seem to be having the same issue, however I downloaded Exodus and Exodus did find my newly created room (via admin.)

When I run PSI 0.9.3 and try to browse, I find the:

And nothing after that. The Psi logo on the bottom left corner keeps refreshing as it seems to be “trying” to connect, usually it stops when it finds what it wants.

Anything I can do, anywhere you can guide me to look at to see what would keep PSI from connecting to the server?

Please note I have tried to retrieve/browse through the chat server with PSI from home and from work to the same server without any results.

Note: I was able to browse through PSI fine on the 2.0.1 release.

Thanks guys!

Message was edited by:

zgambitx

Hola Carlos,

Which version are you using? You shouldn’'t have this problem using the latest nightly build of January 11 (not the installer version). Let me know if you are still having problems.

Regards,

– Gato

Gato,

The problem seems to have been fixed with last night’'s release.

Thank you much!

Just tested out the Jan 11 build with Pandion 2.1.2 beta, and everything looks functional.

Thanks for your hard work and quick turnaround!