powered by Jive Software

muc.room.maxUsers issue

Hey - using the server property “muc.room.maxUsers” worked fine to set the default max users for a muc room in previous versions, but I’ve recently upgraded to Openfire 3.6.4 , and it appears no matter what I do - the default stays at 30. Please help!

Well - I just answered my own question. The fact that I had this issue seems to be a big lack of frontend interface keeping up with the backend changes. After some poking around i found a table

ofMucServiceProp

This is the table your properties need to go into for muc stuff. There appears to be no front end for this.

(assuming your service id is 1 (default conference entry I guess)

insert into ofMucServiceProp(serviceID,name,propValue) VALUES(1,‘room.maxUsers’,‘500’);

Where 500 is the max amount of people you want.

Hi,

I have filed OF-22 to track this request and will probably write a patch to implement it.

thanks,

daryl

Hi,

Just to be clear, this setting sets the default number of maxUsers in a newly created room. It does not place a cap on individual rooms if they are set higher. Am I correct with the above?

daryl

Correct! This just sets the initial “max size” of a room. This can be changed manually on an individual room.

Did you ever get around writing that patch?

Hi Guus,

I have not, sorry.

daryl

I’ve committed a new admin console page to configure default room properties. But note, these settings are only used for rooms which are created via XMPP and not for the admin console (see comment on the JIRA ticket).