powered by Jive Software

Multi user group chat participants list count is not propagating among the other nodes of the openfire cluster

Hi,

Group chat participant count is not sharing among the other nodes of the openfire cluster using hazelcast. I am using 3.8.2 alpha edition(on 21/04/2013 nighly build) since I got problem with 3.8.1 regarding topic was not propagating among other members of the cluster. It is fixed in

** Problem: **


** 1) **Suppose I have 2 users, I logged into same node, In that node room was showing 2 participants.(correct).(muc_1.png)

  1. when I was seeing in second node, It was showing weird by showing 1 particpant in the same room.(weird). I don’t know exactly it is the problem with nightly build or stable 3.8.1 version.(muc_2.png)

Pleas resolve my issue.

thanks

Ravikumar Kotta

I am also having this same issue - Posted about it a couple of weeks ago, but didn’t get any response from developers.

Can any body help regarding this.

We are also experiencing this issue with Hazelcast.

Hopeing for an update soon.

Hi folks -

We’ve had multiple reports of various issues related to MUC features when running in cluster mode. We have opened OF-665 to track. It is not currently assigned, but as time/availability warrants we will move this up the priority list for the developers. Feel free to follow/watch/vote on the issue as appropriate.

Thanks,

Tom

I was not able to reproduce this issue with the latest build (including the fix for OF-665). Could you please re-test using a nightly build dated 04-May-13 (or later)? If you are still seeing this issue, please provide additional details as to how the MUC room is configured, permission settings, etc.

Hi,

I have tested with may5th nightly build, happening same weird things(participants list or count is not propagating to other node). And some times it is showing correctly with out any weird as we discussed(showing same number of participants). I think it seems not fixed, can you please cross check once and give me a reply. please check the room options with permissions.

Use the form below to edit the room settings.

Room ID
Users
Created On
Last Modified
33985
1 / 30
6 May, 2013 1:32 PM
6 May, 2013 1:32 PM

Change the room settings of this room using the form below

Room Name:
Description:
Topic:
Maximum Room Occupants:
Broadcast Presence for:
Password Required to Enter:
Confirm Password:
Show Real JIDs of Occupants to:

thanks

Ravikumar Kotta

Use the form below to edit the room settings.

Room ID
Users
Created On
Last Modified
62016
2 / 30
6 May, 2013 1:21 PM
6 May, 2013 1:21 PM

Message was edited by: ravikumar

I am running svn rev 13645 and can still reproduce this issue with two clients. If I connect both clients to the same node, presence information is correct 100% of the time. If I connect them to different nodes, I seem to run into the problem pretty consistently.

Information about what I am seeing is in this thread - http://community.igniterealtime.org/message/228199

OK - looks like an additional issue with MUC presence when running with clustering enabled. Opened OF-670 to track.

Hi,

Please let me know once it is resolved.

thanks

Ravikumar Kotta

Hi,

Some inconsistencies are there in the presence of clustering. when number of clients are connected through the different nodes(2) of the openfire clustering with presence. and muc room participant count is not propagating among the other nodes. Could you give me a fix.

thanks

Ravikumar Kottau

Hi,

Would you try this scenario.

  1. Connect with one client to the OF cluster node(which is running on IP1) by the remote client(which is running on IP2).

  2. Connect with one client to the other OF cluster node(which is running on IP3) with by the remote client(which is running on IP4).

In this scenario I got the problem with the partcipants count is not propagted among the cluster nodes. this is showing some of the times.(irregularly).

Can you test this scenari, so that it will reproduce based on the comments of http://issues.igniterealtime.org/browse/OF-670?page=com.atlassian.jira.plugin.sy stem.issuetabpanels:comment-tabpanel this page.

thanks

Ravikumar kotta

** 1) **Suppose I have 2 users, each connected to same OF cluster member, In one cluster member is showing 2 participants.(correct).(muc_1.png)

  1. when I was seeing in second OF cluster member, It was showing weird by showing 1 particpant in the same room.(weird) which is showing in muc_2.png

Please find the image for this issue on the top of this page.

You had already opened this issue, http://issues.igniterealtime.org/browse/OF-670?page=com.atlassian.jira.plugin.sy stem.issuetabpanels:all-tabpanel.

But the scenario you have tested is different with the propblem have faced. Please test the scenario which producess the bug.(by connecting 2 clients to the same OF cluster).

Pleas resolve my issue.

thanks

Ravikumar Kotta