powered by Jive Software

Multiple simultaneous clients for the same account... Supported?

Not sure if this is a feature request, bug report, or I’m just doing it wrong. What I’d like to accomplish is to have my openfire server connected to the various IM transports (IM Gateway 1.1.3a), and have a client at work connected and a client at home connected. In this scenario, I’d like all messages to be sent to both clients. I’ve currently got a Spark 2.5.7 client running at home and at work, each with a different Resource name. IM Gateway plugin 1.1.3a and Openfire 3.3.2. The problems I’m having are:

  1. The first time a client connects, it gets the full contact list. On subsequent reconnects, it seems about 50/50 as to whether or not it’ll get the contact list. I’ve found that if I kill both clients, wait about 30 seconds, then reconnect with one, I’ll get the full contact list.

  2. It seems really hit or miss as to which client the messages go to. Sometimes I’ll get home from work after not having received any IMs, and find out all of the IMs got sent to my home client. Again, ideally I’d like to just force both clients to receive all the messages.

Any idea what I can do about these? Are they bugs? Or am I just misconfiguring something?

Thanks in advance,

-superlime

Hrm. Please check what your resource and priority settings are for both clients and we’ll start from there.

Home just reconnected, got the contact list but no presence info (all contacts show as offline).

Resource: h_vaio

Priority: Default? (where do I find priority in Spark? The server “Sessions” tab says Priority 1 currently)

Resource: spark

Priority: Also Default? (Server sessions tab reads ‘0’ for this client currently)

When I get to work I’ll make the work machine unidle and see if the priority changes.

Thanks for the help! Is the scenario I’m trying to do (all messages sent to all clients) even supported? Or would it require modifications to openfire/IM Gateways?

-superlime

Sorry, crazy busy at work today. Current state according to Openfire Sessions:

  • h_vaio is priority 0 (and marked as idle)

  • spark is priority 1 (and marked as online)

The ‘spark’ client currently appears to have full presence info.

I just logged out with the ‘spark’ client, waited about a minute, and then reconnected (with the h_vaio client still connected and idle), and got no presence info. My contacts list is completely empty except for the three IM transports (AIM/ICQ/MSN) and one Openfire user. Sessions tab on the openfire console reports the above state again.

Thanks again for all the help!

-Scott

GATE-368

Sorry to say this, but I experience the same problem.

I use Psi on my workstation and it sets itself auto-idle after some minutes. When I log in via Pandion/Sameplace on my Notebook, only XMPP contacts are shown. Do you need any further information/logs on this one?

Edit: Actually I do get presence changes after a while and filling up the roster. It seems that the second client doesn’t get the initial roster from the im-gateway plugin (or something like that )

I have reported this before and then you fixed it. Now, most of the time I do not get the initial presence flood.

If I am logged in multiple times en re-enable a specific transport in the admin, both resources get the presence flood.

Edit: I use the latest versions of OpenFire, IM-Gateway, Psi and Pidgin

Yep, I see the same behavour - latest versions of openfire, the gateway and spark…

Oops. I didn’t see the fact that this got closed without a fix. I’m still able to reproduce the problem 90-100% of the time, is there anything I can do to help investigate? I could provide admin access to my Openfire server, or more detailed debug logs…

Thanks!

-superlime

I think it has something to do with the persistent roster thingy.

I noticed that there weren’t even any offline IM-Gateway contacts in my roster (but the presences were being sent). Changing the value for plugin.gateway.tweak.persistentroster to true seemed to fixed this for me.

Edit: In my point of view this more a kind of work around and not a proper fix.

Any news here? I tried MxSan’s fix, and while it makes the contact list populate reliably, all contacts show up as ‘Offline’ in the scenario I laid out previously. It’s a step closer, but still pretty broken. :confused:

Thanks in advance!

-superlime