powered by Jive Software

My FDQN starts with a numeric character and is not allowed to be entered when installing

We are using Openfire for an XMMP server with the UC700 software client for NEC phone systems. My issue is that my server name starts with a numeral and when I try to enter the FDQN in the setup it states that I cannot enter a name starting with a numeral. I do not want to change my server name because all of our servers start with numbers. An example of my FDQN is 499servername.domain.loc If I just enter domain.loc I get certificate errors when running my software. NEC says that I must provide a wildcard certificate to make it work but my security team will not allow wildcard certificates. This server is only accessed internally and is not public facing. Does anyone know of a workaround for this or if there is a plan to allow FDQNs to start with a numeral in the future?

Version 4.0.3

I’ve tried to reproduce this with version 4.4.4 of Openfire (the last release at the time of writing). I cannot.

I have added 499servername.domain.loc as an alias of 127.0.1.1 in my /etc/hosts file to simulate your setup.

When I run Openfire setup, I can fill out that value for FQDN without a problem:

image

I can finish the setup without any error. After starting Openfire, the value is shown in the admin console:

image

I can also successfully use an XMPP client to log into the server.

Try updating to a newer release of Openfire and see if that resolves your issue!

Thank you for investigating for me. I will check with our NEC tech to see which version we are running and if we can update the version to latest for a possible fix.