My spark 2.07 client is not "auto updating"

I came in this am and a user pointed out that her spark was prompting her to update to 2.08. I told her to go ahead. I got to my desk and expected to see the same, but no update prompting.

I closed spark and reopened, rebooted, tried again. Still not prompting to update. I did the manual, check for update, and it did tell that v 2.08 was available.

Any ideas? A corrupt client or properties file? I haven’'t tried reinstall as i wanted to see if there was something i should be looking for in case it reoccurs.

This error is reoccuring in my log:

Jan 24, 2007 8:48:26 AM org.jivesoftware.spark.util.log.Log error



at javax.swing.ImageIcon.(

at org.jivesoftware.sparkimpl.plugin.viewer.PluginViewer$3.finished(PluginViewer.j ava:253)

at org.jivesoftware.spark.util.SwingWorker$2$

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at Source)

That’'s an excellent question. The silent check is failing yet an explicit check is not? Hmm. Anyone else experiencing this?



Yes, I had this problem too. I just told it to check, and it found 2.0.8.

The update went fine.

Also, I noticed that 2.0.8 is not available on the website as a download.

I keep the newest version of the Spark download on our server for easy grab when needed,

so I’'m hoping 2.0.8 is downloadable soon.

Spark is a pretty nice litle tool, by the way.


i just downloaded 2.08 and put on my server.