powered by Jive Software

MySQL and Wildfire 2.5.1

Hi folk!

I was investigating ditching ejabberd for wildfire again and ran into an odd problem I’‘d never had before. Specifically, I can’‘t get the MySQL support to work. I use my MySQL server for plenty of other things so I know it’‘s functional. I also created wildfire’‘s db, ran the “set up all the tables” script, and make sure to create it’'s users and test them. What I get is basically a “connection failed” message, with no entries in my MySQL logs. The Jive logs end up saying:


begin log----

java.lang.NullPointerException

at org.jivesoftware.database.DbConnectionManager.setMetaData(DbConnectio

nManager.java:533)

at org.jivesoftware.database.DbConnectionManager.setConnectionProvider(D

bConnectionManager.java:356)

at org.jivesoftware.wildfire.admin.setup.setup_002ddatasource_002dstanda

rd_jsp._jspService(setup_002ddatasource_002dstandard_jsp.java:194)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:427

)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(

WebApplicationHandler.java:822)

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilt

er.java:118)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilte

r.java:52)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(

WebApplicationHandler.java:813)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:43)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(

WebApplicationHandler.java:813)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacte

rEncodingFilter.java:41)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(

WebApplicationHandler.java:813)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(

WebApplicationHandler.java:813)

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicati

onHandler.java:494)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:5

at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplication

Context.java:624)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1434)

at org.mortbay.http.HttpServer.service(HttpServer.java:896)

at org.mortbay.http.HttpConnection.service(HttpConnection.java:814)

at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:981)

at org.mortbay.http.HttpConnection.handle(HttpConnection.java:831)

at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:

at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:366)

at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

2006.03.27 18:53:26 [org.jivesoftware.database.DefaultConnectionProvider.getConn

ection(DefaultConnectionProvider.java:68)] Warning: DbConnectionDefaultPool.getC

onnection() was called before the internal pool has been initialized.

2006.03.27 18:53:26 [org.jivesoftware.database.DbConnectionManager.getConnection

(DbConnectionManager.java:116)] WARNING: ConnectionManager.getConnection() faile

d to obtain a connection.


end log----

I have tried this using 127.0.0.1, localhost, and syphon.vorpalcloud.org (full host name) as the mysql hostname. I first tried a tarball installation pointing to jdk1.5.0_06. Then I tried the rpm dist that includes the jdk. I am not really getting any real indication that wildfire is “even trying” to connect to my mysql server. Any ideas? If I were to hedge a bet, I’‘d say it’‘s something weird with my setup, since I haven’'t see a single other complaint in the forums and this is kind of a major thing, you know?

Lets see… some data points:

OS/Dist: RedHat Enterprise Linux 3 (U7)

MySQL: 4.0.20

Fresh installation.

Not sure what else to say. ;D Plenty of memory, disk space, processing power, that sort of stuff.

Hey Daniel,

The exception you pasted is not the root exception. Could you post the entire list of exceptions you have in the error.log? If the list is too big feel free to send it to me by email (gaston at jivesoftware dot com). My blind guess is that there is a connectivity problem between the server and MySQL. For instance, if Wildfire and MySQL are running in different machines then MySQL may not be accepting connections from remote machines.

Regards,

– Gato

DOOOOOOOOOOOOOOOOOOOOOOHHHHHHHHHHHHHHH!!!

Thank you =) That particular error snippit repeats itself like 2 or 3 times for each occurance, so I never got around to looking even further up the log to where it says quite blatantly:

java.sql.SQLException: Access denied for user: ‘‘wildfire@syphon.vorpalcloud.org’’

(Using password: YES)

Which makes perfect sense since I only granted wildfire@localhost access. C-R-A-P.

Thanks for giving me the nudge I needed to find that. ;D

Hi Daniel,

this seems to be a configuration and not a connection issue.

public static void setConnectionProvider(ConnectionProvider provider) { };[/i] is failing, so it seems that you did specify an invalid ConnectionProvider. I don’'t have a setup window in front of me but could you please post what you did enter?

You did read MySQL DB setup[/url] as you did setup the database so I wonder if you made a minor error while entering the information during Wifi setup.

LG

See above stupidity on my part. ;D