powered by Jive Software

Naming conventions?


whenever I take a look at thread dumps or do some profiling I have a lot of difficulties to map or filter out things.

  • One should name threads in a way which allows to identify the source of them within a stack trace. A name “pool-openfire6000” is useless for me.
  • Plugins should be forced to be in a package “org.jivesoftware.openfire.plugin(.pluginname)”. Currently the monitor plugin uses also “org.jivesoftware.openfire.reporting.” - so one may want to remove the pluging or one does need to exlude this class in the profiler.
  • System properties should also get proper names. While I see that “gateway." are gateway properties it would make more sense to use "plugin.gateway.” for them.

I will sooner or later create an issue for the “pool-openfire6000” problem, as soon as I have identified the root problem.

Most changes should be quite easy to do, so this would be more some kind of refactoring than fixing bugs.