New 3.0.1 install - nohup.out -

when i start wildfire with sh -x ./wildfire start

the last line is this:

  • echo ‘‘Starting wildfire’’

Starting wildfire

  • nohup /opt/sun-jre-bin- -server -Dinstall4j.jvmDir=/opt/sun-jre-bin- -Dinstall4j.appDir=/opt/wildfire -Dexe4j.moduleName=/opt/wildfire/bin/wildfire -classpath /opt/wildfire/.install4j/i4jruntime.jar:/opt/wildfire/lib/activation.jar:/opt/w ildfire/lib/bouncycastle.jar:/opt/wildfire/lib/commons-el.jar:/opt/wildfire/lib/ hsqldb.jar:/opt/wildfire/lib/jasper-compiler.jar:/opt/wildfire/lib/jasper-runtim e.jar:/opt/wildfire/lib/jdic.jar:/opt/wildfire/lib/jtds.jar:/opt/wildfire/lib/ma il.jar:/opt/wildfire/lib/mysql.jar:/opt/wildfire/lib/postgres.jar:/opt/wildfire/ lib/servlet.jar:/opt/wildfire/lib/startup.jar:/opt/wildfire/lib/wildfire.jar com.install4j.runtime.Launcher start org.jivesoftware.wildfire.starter.ServerStarter false false /opt/wildfire/bin/…/logs/stderror.log /opt/wildfire/bin/…/logs/stdoutt.log true true false ‘’’’ true true 0 0 ‘’’’ 20 20 Arial 0,0,0 8 500 ‘‘version 3.0.1’’ 20 40 Arial 0,0,0 8 500 -1 -DwildfireHome=/opt/wildfire -Dwildfire.lib.dir=/opt/wildfire/lib start

  • exit 0

gentux wildfire # nohup: appending output to `nohup.out’’

The ports are opened, verified with netstat -a and nothing is using 9090 or 9091.

When i start it - i can get to localhost:9090 and view the first install page -but when i click continue it gives me an HTTP ERROR: 500 Request URI=/setup/setup-host-settings.jsp



Hi Matt,

What are you getting in /opt/wildfire/logs/error.log file?

heres the start: 2006.09.01 10:18:46 org.jivesoftware.wildfire.container.AdminConsolePlugin.initializePlugin(AdminCon Trouble initializing admin console

org.mortbay.util.MultiException[ Address already in use, Address already in use]

at org.mortbay.http.HttpServer.doStart(

at org.mortbay.util.Container.start(

at org.jivesoftware.wildfire.container.AdminConsolePlugin.initializePlugin(AdminCo

at org.jivesoftware.wildfire.container.PluginManager.loadPlugin( :396)

at org.jivesoftware.wildfire.container.PluginManager.access$200( :47)

at org.jivesoftware.wildfire.container.PluginManager$

at java.util.concurrent.Executors$ Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$ Source)

at Source) Address already in use

at Method)

at Source)

at Source)

at Source)

at org.mortbay.util.ThreadedServer.newServerSocket(

that WAS in my log file - i have since cleared the logs, started and stopped it again, and error.log is empty.

I think the above means that it oculdnt open the port (probably was written when I tried to start it two times in a row).

Hi Matt,

That’'s because when you try to start Wildfire, you may already have another Wildfire running. When you said that you had 500 error, it seems to me that the subsequent startup has caused trouble also to the original Wildfire. My suggestion is that you do as follows:

  1. Run ps auxw | grep wildfire (the ps options depends on your flavor of unix).

  2. Take note of the process id (pid) of the running java process obtained from ps

  3. Run kill -TERM all the pids

  4. Delete all files in /opt/wildfire/logs/

  5. Start your Wildfire once and only once.

  6. Run ps auxw | grep wildfire again to verify that it’'s running.

  7. Login to http://yourhost:9090

  8. If there’'re still errors, look at /opt/wildfire/logs/error.log once again. You may want to post it here.

Took all of those steps to no avail. I had actually tried those earlier when i found them in a search…

error.log is still empty, and still says nohup when i start wildfire


Message was edited by: mellman


the nohup message is just fine. But you should see in your log files that Wildfire did either open port 9090 or that it did fail. If it fails to open port 9090 then please check which process is using it.


gentux logs # more info.log

2006.09.01 12:46:06 Wildfire 3.0.1

2006.09.01 12:46:14 Admin console listening at:

gentux logs # more stdoutt.log

Wildfire 3.0.1

Admin console listening at:

That was the only things inside of my logs.


so http://servername:9090/ should display the setup page, or cause an error you’'ll see in the log files and probably in the browser.


Yeah - Tried all of that, still nothing in the error.log file, and when i click continue on the language setup page it gives me HTTP ERROR: 500



-BTW - Sorry for being such a noob at this…I do greatly appriciate all of your help though!

Message was edited by: mellman


is it possible that you did disable Cookies in your browser? It may help to add the server to your trusted pages.


Cookies are enabled and working confused

I get the same issue, the HTTP ERROR 500 on version 3.0.0 that I just tried to install. is this a java issue of some sort?

my java version is:

java -version

java version “1.5.0_06”

Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)

Java HotSpot™ Client VM (build 1.5.0_06-b05, mixed mode)

Not the absolute latest but hm.

I feel like something isn’'t configured right with wildfire, is there an install i need to make? and run that first?


it is not a java issue. Probably a permission issue. Which users starts Wildfire? “jive” as suggest by Jivesoftware? And if it’'s jive does it own the directories are is root the owner?


I’'ve been manually running the program from root - not using a startup script yet or anything

I tried starting this program as jive (created the user, chown’'ed the directory to him, gave jive rwx… still no dice!

Is there no manual way to set this thing up? Nobody else here has ever setup a wildfire server…the software and feature set seems nice but I may have to switch to another server if i can’'t get this figured out sooner rather than later.


the setup is really easy, and for nearly all users it runs fine. I recently did post an installation guide at but I worry that it will not help you.

Try to edit your /etc/hosts file as described in - I have no other idea why the setup fails for you.

Or try to use another browser on another client.




The server was renamed (Linux) and never rebooted. I rebooted the server so that it came back up with the correct hostname and now the initial setup starts.