powered by Jive Software

New Installation and Configuration of OpenFire and Spark 2.8.3... NEED HELP!

The installation and configuration of the OpenFire went fine. Connected to active directory, all seems fine. I installed the Spark IM and I can’t connect. Here are my logs. My computer can ping the AD server and vise versa. I opened the Firewall port 5222 inbound and outbound on my Computer. I also disabled all firewall monitoring and that didn’t work either. I have also tried installing “Spark” ON the Server where OpenFire is configured and still can’t log in. I haven’t found any documentation or support that seemed to address this and I am stuck. I will keep reading after my migraine goes away, but if you can assist I would appreciate it.
error.log (10.1 KB) output.log (2.1 KB)

On the Openfire admin console, first page after login, what is listed as the XMPP domain name for the server, and what is listed as the FQDN (hostname)?

Openfire Admin Console: Server Information

deltekdevhm1.tti-corp.com

Is that the XMPP domain name or the FQDN?

Yes for both. Same name.NAMES.docx (37.5 KB)

From the Spark error log, I think you are using the value ‘tti-corp.com’ for domain when you login with Spark. You should instead use the value that’s configured as the XMPP domain name in Openfire: deltekdevhm1.tti-corp.com

When I try that with the IM installed on the server I get: Unable to verify certificate… When I try the same logon from my PC I get the Unknown Connection Error.

Openfire by default uses a self signed certificate. You need to tell Spark to accept these (or replace the certificate in Openfire with a proper one).

As for the connection issue on your PC: that might be a networking issue. Does that domain name resolve to the correct server? If not, then you can configure Spark to use a specific server in its advanced settings, or, alternatively, you can add DNS SRV records in your nameserver to map the XMPP service to the correct host.

GOT IT!! Firewall on server needs to have Ports 5222 open as well.

I also had to select Accept all certificates (Self-Signed/expired/not trusted) AND Disable certificate host name verification and configured and tested the SMS Setting.