powered by Jive Software

New Installation OpenFire 3.9.3 w/ Server 2008 SBS

I downloaded the latest version of Openfire v3.9.3 with JRE support for Windows. I succesfully installed it and when the program opened up to start, it gave me a ton errors off the bat from the executable (opefire.exe). So, what I ended up doing was installing the openfire-service into the services part of server. I’m running Windows 2008 SBS SP2 (Small Busines Server) and I setup a basic domain with a couple of users. I’m running this in a test environment to see how well Openfire works for me (Oracle VM).

Once I got the service installed and started, I browsed the internal admin site using http://127.0.0.1:9090. I managed to get the setup GUI. I went through all the prompts and when I got to the part where it asks Profile Settings, I set it to Directory Server (LDAP). When I went to the next page to enter the LDAP server and authentication, this is where it breaks down for me.

I entered the server type as Active Directory, host as my IP address of the same server (10.0.2.5, tried 127.0.0.1 and hostname as well). I’m using the SBS server itself as the AD, DNS and Openfire server, so everything is hosted in one machine. I left the default port of 389. For the Base DN, his is where I’m confused. All the installation tutorials and docs that I have looked up, use the default Users CN for the Base DN. The issue with 2008 SBS is that they put in this heirarchy:

xxxx.local -> MyBusiness -> users -> SBSusers.

How do I go about putting this in the Base DN slot? This is what I put in there:

CN=SBSUsers;dc=xxxxxx;dc=local

And for my authentication, I put the following:

CN=admin,dc=xxxxxxxx;dc=local

I pressed the grey test settings button and it just doesn’t do anything. The screen doesn’t say if it was successfully or not. I was using the stock IE7 but that gave me 1825 errors, so upgraded to IE9. The 1825 errors went away but now I don’t get any connectivity to the LDAP server. Is there a specific version of JRE that I need to run? I thought the setup included the JRE but I downloaded the latest version from Oracle, which is 1.7 build 65 to see if that fixed the problem or not.

I tried to download 3.9.2 and still the same thing. I’ve also tried Firefox 30 and it doesn’t say anything when I run the test for connectivity Is there something I’m doing wrong? It seems pretty straight forward but this issue is strange.

Hey you might want to check my thread here: openfire and AD integration with Zentyal

Maybe it will give you some inspiration.