powered by Jive Software

New Mysql jdbc driver broken

I recently updated openfire from 3.3.2 to 3.4.1. Initially, it was unable to function with our MySQL 4.0 server. The server would hang during startup. I enabled the query log, and found that the server was issuing only one command; it seemed like the JDBC driver wasn’t able to detect the end of the result.

I resolved the issue, temporarily, by replacing lib/mysql.jar with the version that was included in 3.3.2. After that, the openfire server worked properly.

The next day, I upgraded the MySQL server to 5.0 (as included with CentOS 5). I then replaced lib/mysql.jar with the version that was included in 3.4.1, and the server appeared to function normally. However, when I looked at error.log, I saw that it was throwing exceptions. A portion of error.log is attached.

Once again, I resolved the issue by replacing lib/mysql.jar with the version that was used in openfire release 3.3.2. The version currently distributed certainly seems to be broken.

Hey Gordon,

Sorry to hear that the new jdbc driver version is not working for you. Could you try with the 5.0.8 instead? Updating to the 5.* family brings lots of performance and memory improvements. We tried the new driver in our local QA environments and they worked fine.

Thanks,

– Gato

5.0.8 seems to work, with a limited amount of testing.

I won’t be able to test further than that. I’m moving to PostgreSQL.

Thanks for looking at the problem, though.