New Open Fire Install Cannot Connect on Port 5222 On Debian Box

Hello All,

I just installed OpenFire yesterday using this simple Tutorial install-p1.shtml

The install was fairly simple and I did get the server working and was able to connect to users on a local net using Pidgin and port 5223.

However, I noticed that I was not able to connect using port 5222 when SSL and TLS were both turned off on the server. Matter of fact I have not been able to connect at all using 5222. Using Wireshark on the server it looked like there was some type of stream error. I am not a programmer so trying to decipher the log files have been very difficult. Viewing most other forums on the initial admin webpage 5222 is available. By default the server ports listed as available on the initial admin logon web page for me are:

All addresses

Client to Server
The port used for clients to connect to the server using the old SSL method. The old SSL method is not an XMPP standard method and will be deprecated in the future. You can update the security settings for this port.
All addresses

Admin Console
The port used for unsecured Admin Console access.
All addresses

HTTP Binding
The port used for unsecured HTTP client connections.
All addresses

HTTP Binding
The port used for secured HTTP client connections.
All addresses
3478 & 3479

STUN Service
The port used for the service that ensures connectivity between entities when behind a NAT.
All addresses

Flash Cross Domain
Service that allows Flash clients connect to other hostnames and ports.

So why is port 5222 not available for me.

On the server I ran: netstat -nap | grep 5222

tcp 0 0* LISTEN

So it looks like that port is listing and I do get a stream error on the server on that port using wireshark…very odd?

Maybe someone else has seen this problem or has a logical next step idea.



One more thing I found odd was I ran

netstat -anp | grep 5223

tcp6 0 0 :::5223 :::* LISTEN 25814/java
tcp6 0 0 ESTABLISHED 25814/java


netstat -anp | grep 5222

tcp 0 0* LISTEN 9312/beam

So to me it seems like maybe the port is not configured properly or something.



Hello ALL!!!

Please help!!!

gives an error "There was an error communicating with server. Details: Disconnected "

log warn:

No ACK was received when sending stanza to: org.jivesoftware.openfire.nio.NIOConnection@7a6757 MINA Session: (SOCKET, R: /, L: /, S:

Server Properties
Server Uptime:
52 minutes – started Nov 10, 2010 5:26:49 PM
Openfire 3.6.4
Server Directory:
Server Name:
Java Version:
1.6.0_18 Sun Microsystems Inc. – OpenJDK Server VM
Host Name:
OS / Hardware:
Linux / i386

ports : 5222

Client to Server

nur, please don’t post the same thing in several older threads, just start your own thread for your issue.

Hi !

My “netstat” is the same and everythings works really well.

Have you tried a good/usable client so?? I am successful

with Psi and Gajim.

If you cannot connect out of the box, configure the clients

to explicit use the ip-address of the server.

In my network [debian], I use DNSMASQ and have specified

a SRV record for xmpp. The client usually makes a DNS request

to the domain to obtain that record, which must point to the

xmpp server name [which, in turn should also be in DNS].

I fumbled with this in the beginning;Psi does it wrong, but Gajim makes

it right [no direct setting of the servers ip-address necessary].

To make matters worse, it looks like some of the programming libraries

seems to have bugs in this. Even the most docs are speaking about a connection

to the server, which lead to people configuring host-names;But domain is - so

far I finally understand all right - the right thing.

Hope, this helps.