powered by Jive Software

New setup... can''t get statuses

Hi-

Trying to get this setup and right now I get this in the logs:

2006.04.20 12:54:03 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/1-1

2006.04.20 12:54:06 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/23-1

2006.04.20 12:55:51 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/22-1

2006.04.20 12:56:49 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/1-1

2006.04.20 13:01:24 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/23-1

2006.04.20 13:01:50 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/1-1

2006.04.20 13:01:54 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/1-1

2006.04.20 13:02:03 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/1-1

2006.04.20 13:02:58 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/23-1

2006.04.20 13:03:24 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/1-1

2006.04.20 13:04:48 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/2-1

2006.04.20 13:09:44 [java.util.logging.Logger.log(Unknown Source)

] Ignored NewCallerIdEvent for unknown channel Zap/1-1

Not seeing anything on the Spark clients. Asterisk shows that the plugin is logging in okay to the asterisk server.

Any help would be appreciated,

Bill

On further review of the serve debug log, everything seems like it’'s working fine. I see new phone events when calls come in, etc.

But I still don’'t see statuses on the Spark client. Is there some special client plugin or something that I need to do to the client to get it to pay attention to the Phone Events?

Thanks,

Bill

In case it helps, here’‘s what’‘s happening in the debug.log. See? Doesn’‘t it look like it’'s working properly on the server side? Why would I not get statuses at the client.

2006.04.20 16:41:40 Asterisk-IM: Processing NewState:UP event channel : SIP/7201fruct-1020 id: 1145576430.6021

2006.04.20 16:41:40 Asterisk-IM OnPhoneTask called for user PhoneUser{id=3, username=’‘FredF’’}

2006.04.20 16:42:33 Asterisk-IM HangupTask called for user PhoneUser{id=3, username=’‘FredF’’}

2006.04.20 16:42:33 Cannot destroy non-existent CallSession with id: 1145576430.6021

Do you have SIP/7201fruct mapped in the admin console as a device?

Under phone mappings? Yes. The list of extensions was populated and I mapped that one to one of the users. (A user DIFFERENT from the workstation I’‘m sitting at, since I understand that you don’'t necessarily see your own statuses in Spark.) I do see when that users goes idle…just from inactivity on the PC… but I never see any phone statuses.

Bill

The easiest way to see if on the phone is working is to look at the sessions tab in the admin tool.

Here’'s that tab:

If I update that tab while on a call nothing changes…

Bill

Hi Andrew-

Anything for me to try on this? I’'m onsite all day and would love to be able to wow them with the presencing when they come in on Monday.

Bill

When you look in the spark debug tool, can you see phone-event packets come from the server. If you do see those packets post them.

I’‘m having the same issues but I don’‘t know what the spark debug tool is. I’'d be glad to post some info if I just knew what you were asking. A search on the forums only brought back this post in reference to the spark debug tool.

figured out what you meant. Am testing with the client traffic window now, will update /w another post once I try some things on my end.

Message was edited by: NathanWS

Ok here’'s what comes across when testusers calls nathanws (callerid NathanC)

(These are the messages recieved by testusers)

From phone.fqdn 12:11:06

Here’'s what the server shows:

2006.06.14 12:09:57 Connect Socket[addr=/192.168.1.115,port=1901,localport=5222]

2006.06.14 12:11:06 Asterisk-IM RingTask called for user PhoneUser{id=2, username=’‘testusers’’}

2006.06.14 12:11:10 Asterisk-IM: Processing NewState:UP event channel : SIP/22-16c4 id: 1150301465.35

2006.06.14 12:11:10 Asterisk-IM OnPhoneTask called for user PhoneUser{id=2, username=’‘testusers’’}

2006.06.14 12:11:10 Asterisk-IM OnPhoneTask: setting presence to away for PhoneUser{id=2, username=’‘testusers’’}

2006.06.14 12:11:10 Asterisk-IM: Processing NewState:UP event channel : SIP/24-b582 id: 1150301465.34

2006.06.14 12:11:10 Asterisk-IM OnPhoneTask called for user PhoneUser{id=1, username=’‘NathanWS’’}

2006.06.14 12:12:06 Asterisk-IM HangupTask called for user PhoneUser{id=2, username=’‘testusers’’}

2006.06.14 12:12:06 Asterisk-IM HangupTask called for user PhoneUser{id=1, username=’‘NathanWS’’}

2006.06.14 12:12:06 Cannot destroy non-existent CallSession with id: 1150301465.34

2006.06.14 12:12:43 Asterisk-IM RingTask called for user PhoneUser{id=1, username=’‘NathanWS’’}

2006.06.14 12:12:44 Asterisk-IM: Processing NewState:UP event channel : SIP/24-4e3f id: 1150301562.37

2006.06.14 12:12:44 Asterisk-IM OnPhoneTask called for user PhoneUser{id=1, username=’‘NathanWS’’}

2006.06.14 12:12:44 Asterisk-IM: Processing NewState:UP event channel : SIP/22-95fb id: 1150301561.36

2006.06.14 12:12:44 Asterisk-IM OnPhoneTask called for user PhoneUser{id=2, username=’‘testusers’’}

2006.06.14 12:12:44 Asterisk-IM OnPhoneTask: setting presence to away for PhoneUser{id=2, username=’‘testusers’’}

Message was edited by: NathanWS

I’‘ve deleted the accounts and mappings and then recreated them. This time I am able to get an ‘‘on the phone’’ presence for one of the users but not the other, here’'s the interesting part of the server log.

2006.06.14 16:27:24 Asterisk-IM RingTask called for user PhoneUser{id=4, username=’‘testuser’’}

2006.06.14 16:27:25 Asterisk-IM: Processing NewState:UP event channel : SIP/22-dca0 id: 1150316843.47

2006.06.14 16:27:25 Asterisk-IM OnPhoneTask called for user PhoneUser{id=4, username=’‘testuser’’}

2006.06.14 16:27:25 Asterisk-IM OnPhoneTask: setting presence to away for PhoneUser{id=4, username=’‘testuser’’}

2006.06.14 16:27:25 Asterisk-IM: Processing NewState:UP event channel : SIP/24-26f8 id: 1150316843.46

2006.06.14 16:27:25 Asterisk-IM OnPhoneTask called for user PhoneUser{id=3, username=’‘NathanWS’’}[/i]

There is no ‘‘setting presence to away’’ for the NathanWS user.

NathanWS recieves this from Testuser:

/i

testuser recieves nothing.

So far I have changed wildfire domain to a FQDN, recreated all accounts and mapping, reinstalled the plugin.

Any more suggestions?

Update: I deleted all users a couple of times and suddenly I was getting consistent phone presence results. I don’'t know why exactly but it appears to be working now.

Message was edited by: NathanWS

Message was edited by: NathanWS