powered by Jive Software

New to OpenFire

Hey,

I am new to Openfire ad XMPP completely. I am a ColdFusion developer looking to learn the IM Event Gateway built into ColdFusion. The book I am reading said that Jive Software was the best and because, I just wanted to do development right now, and not actual runtime IM application I found openfire.

Anyways, I installed OpenFire on my Vista Ultimate laptop and ran through the stup process using the embedded DB because my SQL Server Express DB Engine has ben giving me issues lately that I haven’t fixed yet. But now I can’t figure out my login credentials for the Admin Console. I know what I put in for Administrator’s email and Password, but those two things don’t seem to work.

Right now I put in:

User Name: “what I put in as the administrator’s email in the setup process”

Password: “what I put in for the password in the setup process”

Is that the wrong way to do it?

hi,

got the same bug during set up with the current version of openfire.

after the setup process u have to simple restart openfire (./openfire stop -> ./openfire start)

after the restart of openfire ur defined login-data will work

greez

Thank you very much.

I actually restarted my computer and it started to work. I just hadn’t had time to get back on here to post my solution yet.

I’m having the same problem. However restarting the service or rebooting the computer did not fix the problem. I am still unable to login.

I’m running on Windows XP Pro and using the embedded database. I did try deleting the setup tag in the XML file and running setup again; I put in new credentials but I am still unable to login. I get “login failed, make sure your username and password are correct”.

Any suggestions?

Rosencrantz, you should use admin as a login. In case you are trying to login with that email address you have specified.

Thanks. I did try admin though. I also tried the email address, and administrator. I also tried variations on case. I tried them with the password I specified as well as with the default “admin” password, as well as a blank password. None of these worked. “admin” and the password I specified should have worked.

I also tried uninstalling/reinstalling, running setup, rebooting and loggin in: same message.

What I found was that to actually do a full uninstall you have to uninstall it and then delete the folder from your Program Files. So maybe try that.

David Long

Web Application Developer

Cage Data, Inc.

6 N. Main St. Suite 201

Wallingford, CT 06492

Rosencrantz, you said you have restarted the service, Did you tried to use it with launcher, not as a service? You always have to restart Openfire server it after a setup, there is a bug not letting to login just after the setup.

Thanks for the replies. I did delete the folder from Program Files after the uninstall before reinstalling because I noticed it left stuff behind. I did not clean up anything in the registry though.

I initially tried it running from the launcher, and after that didn’t work I installed the service, which also did not allow me to login.

I’ve missed my opportunity to use this for my current project and instead have gone with an alternative solution; however I will likely try Openfire again in the future.