powered by Jive Software

Newb Setup Help

I’m a Linux newb, and with some help, have Openfire 3.8.1 Alpha, with Java 1.6.0_41 on an embedded Jetty database in CentOS 6.3. Because I have users on multiple OSes, I would prefer to have them use the web interface from Sparkweb for client installation simplicity.

I have downloaded the SparkWeb files and extracted them, but have no idea what to do with them. I’ve read the forums about firewall ports, etc., but for some reason can’t connect to it.

I have the firewall disabled currently. I have tried putting the sparkweb folder in the openfire/plugins/admin/webapp folder, and browsing to http://servername:7070/openfire/plugins/admin/webapp/index.html, but get nothing. If I open the index.html file by right clicking it, I get the login page, but when I try to log in, nothing happens. Here’s the connection content info of my index.html file:

return {

Server: “accopenfire”

Port: “7070”

connection Type: “socket”

autologin: “false”

}

I’ve tried “http” as the connection type, but that didn’t work either.

Scott

Oh yeah, if I open localhost:7070, I get a page that says “Openfire HTTP Binding Service”

I also tried to watch the flash video that’s in the folder, but can’t get it to play anywhere, not even with SWF Player.

hmm… i could be mistaken, but I think wroot has said before that SparkWeb isn’t relaly currently maintained and consequently there might be missing documentation, etc.

For me, downloading the zip, extracting, then stuffing into a directory that is served via the webserver application ON the same server as OpenFire is running worked. I use Apache, so I stuck the sparkweb folder into my DocumentRoot directory, restarted the Apache service, and it worked.

So now i go to:

http://www.server.com/sparkweb/SparkWeb.html

if you dont like having to go to the specific SparkWeb.html page, setup an index.html page that will redirect to the SparkWeb.html page…

something real basic like:

This page will redirect to http://www.server.com/SparkWeb.html

There is no need to change the connection type from socket, this is how SparkWeb will connect to the OpenFire server.

Since sparkweb is calling back to localhost, there shouldn’t need to be any additional ports open for it to work (besides port 80 for HTTP traffic from the server).

Spark is written in Java and therefore is inherently cross-platform… this is the “big deal” about java - being cross-platform that is. The only real differences in the spark version would be the default skins, startup processes (which directory has the profile, etc…). The installation for each system is a bit different due to the variances in OS’s… but none-the-less Spark should work on most systems out there with little fuss.

Are you deploying Spark/Openfire internally (for employees/contractors) or externally (for customers/clients)? How much control do you have over the systems that will be running Spark? Do you have Active Directory/Windows Domain Services or something else?

If sparkweb will suite you just fine, then great. Otherwise you might want to take a look at deploying spark again…

just realized you might not have apache running on your shiny new centos box!

sudo yum install httpd -y

(httpd is the name of the apache installation from the centos repos - http for web stuff - d for daemon (service in windows speak))

now stuff your sparkweb directory into the /var/www directory so that the path is /var/www/sparkweb

then do

sudo chown -R apache:apache /var/www/sparkweb

that will change the ownership of the sparkweb directory and all subdirectories and files to the apache user (automagically created when you install apache)

now edit your apache config file

sudo vi /etc/httpd/conf/httpd.conf

find where it says:

ServerName

and add your hostname that people will put into their browser to access spark web.

so mine looks like:

ServerName www.server.com

now find where it says DocumentRoot and update to point to your sparkweb directory

so mine looks like:

DocumentRoot “/var/www/sparkweb/”

EDIT: Left out of original post:

now find the <Directory “/var/www”> section and change this to whatever your DocumentRoot is set to:

so change to:

<Directory “/var/www/sparkweb”>

now save changes and close the file.

now do:

sudo service httpd start

sudo chkconfig httpd on

test it out… should work by pointing your browser to the centos server… you will need to put the index.html redirect page into the sparkweb directory if you want it to automatically serve the sparkweb page

so if a user goes to:

http://www.server.com

with the index.html page it will serve the SparkWeb.html page

without this, users have to go to

http://www.server.com/SparkWeb.html

to load sparkweb.

Hop that helps!

There is a simpler way of doing this :slight_smile:

Put sparkweb in the OPENFIRE_HOME/resources/spank folder. If you want to use socket, change port to 5222. If you want http-bind, then change to http-bind and keep port as default 7070 or whatever you have changed it to in Openfire admin web console.

Read the document at http://community.igniterealtime.org/docs/DOC-1400 for more information about configuring jive_sparkweb_getConfig

oh the documentation! How typical SysAdmin of me to skip right past it! lol!

Anyways, this way seems a lot simpler and less to maintain on your centos server… although both ways will work.

Thanks Dele!

I followed the instructions for apache setup, but for some reason, it still shows the “HTTP Binding” web page, even though I’ve renamed that to index.html.old, and renamed the sparkweb.html to index.html. I’ve restarted the httpd service several times. Weird.

OK, that’s gotta be pulling from somewhere else. I cut the old index file out of the folder completely and moved it to the desktop to eliminate that as a possibility. I need to go searching.

Edit: I found it. There was a holdover in the spank folder. Not sure why web traffic is still being directed there. Any ideas?

did you set your DocumentRoot directory correctly? by default i think it points to /var/www/htdocs or something… which will have a sample index.html page…

Also, I’d probably change back to socket connection… its teh default and works well for me.

also, try disabling SELinux – i’ve had issue before with it causing apache to do some weird stuff…

sudo vi /etc/selinux/config

change SELINUX=enforcing to SELINUX=permissive

mine looks like:

This file controls the state of SELinux on the system.

SELINUX= can take one of these three values:

enforcing - SELinux security policy is enforced.

permissive - SELinux prints warnings instead of enforcing.

disabled - No SELinux policy is loaded.

SELINUX=permissive

SELINUXTYPE= can take one of these two values:

targeted - Targeted processes are protected,

mls - Multi Level Security protection.

SELINUXTYPE=targeted

you will have to reboot for this to take effect.

also make sure you have proper ports open on the centos box – for testing (and only for testing!) you can disable the firewall by doing:

sudo service iptables save

sudo service iptables stop

sudo service ip6tables save

sudo service ip6tables stop

that takes effect immediately with no reboot required…

Just saw your edit:

what is the path it was being directed to? /var/www/sparkweb should be what you have setup as your DocumentRoot right?

Also, I forgot in my original post you will need to set the in the httpd.conf to whatever you set the DocumentRoot to… this might be your issue…

its located righrt below the DocumentRoot section:

<Directory “/var/www”> should be changed to <Directory “/var/www/sparkweb”>

try that, restart apache and see what happens…

I already had selinux set to permissive. My document root line says:

DocumentRoot: “/var/www/sparkweb/”

I already have iptables disabled as well.

Grrr. It still brings up that HTTP Binding page.

Silly question - is OpenFire serving web instead of Apache?

it is serving webpages but should only react to the ports its config with… ie 7071, 9091, or whatever you set the web admin to be on…

maybe its time to pull the plug on the apache setup and try Dele’s way:

@Dele Olajide wrote:

There is a simpler way of doing this :slight_smile:

Put sparkweb in the OPENFIRE_HOME/resources/spank folder. If you want to use socket, change port to 5222. If you want http-bind, then change to http-bind and keep port as default 7070 or whatever you have changed it to in Openfire admin web console.

Read the document at http://community.igniterealtime.org/docs/DOC-1400 for more information about configuring jive_sparkweb_getConfig

might be less to manage anyways… :-/ My setup works as described above…but maybe there is some “magic” i setup somewhere and forgot about… sigh

EDIT: to undue apache:

sudo chkconfig httpd off

sudo service httpd stop

and if you really want…

sudo yum remove httpd -y

that will cleanup apache and remove it… if you are worried about having the webserver installed…

Message was edited by: Jason

OK, I don’t get it. I gave up, and started looking for some other web-apps that I could try. I downloaded Candy, Jappix, etc., and was in the process of extracting Candy, and went to the localhost page and, get this, SparkWeb WORKED! Weird. I didn’t do anything, and it started working. Maybe the Linux fairies paid me a visit while I was out of the office sick most of the week.

Anyway, it’s got the basic chat feature, but for some reason it’s not able to find the conference rooms. I’ll work on that, and the background color later on.

One quick question - does anyone know if it’s possible to remove the hostname box from the login screen? It’s the server name, which will only confuse my users.

Glad you got it working! the linux gods do that sometimes :stuck_out_tongue_winking_eye:

you can hardcode the server in the SparkWeb.html file…

otherwise you will have to compile your own shockware flash objects to replace the SparkWeb.swf file… the latest source is at:

http://fisheye.igniterealtime.org/browse/sparkweb/trunk

you will find it call the server value from SparkWeb.mxml inside the SparkWeb direcotry… i’ve never worked with flash stuff before so its out of my leauge… :-/ good luck!