powered by Jive Software

Newbie connection problems

Hi all, I am a Jives and Jabber newbie. I’'ve setup the latest release on my Windows XP machine, and then created an account name “test” through the web interface.

When I try to connect, either with Gaim or Exodus, all I get is a “Couldn’'t connect to host” message. My server name is 127.0.0.1. In Gaim’‘s account windows, I put screen name “test”, server 127.0.0.1 and resource “gaim”. All other options have their default value. I have turned off my firewall, and it still doesn’'t connect. Please help me where to look at now.

Thanks in advance

If you could create the account using the JM admin pages, it is not likely to be a JM problem.

Things to check on Gaim:

Protocol: Jabber - (I made that mistake by accident)

Server: 172.0.0.1 or else the local computer name

Things to check on Jive:

when you installed Jive did you disable SSL (I think its enabled by default), if you didn’'t you may have to use the “Show more options” in Gaim account page. I would not use SSL by default as it brings other complications.

I had no problems with Gaim/JM

Hope that helps,

Conor

Things to check on Gaim:

Protocol: Jabber - (I made that mistake by accident)

Server: 172.0.0.1 or else the local computer name

The protocol is correct. The server name should be 127.0.0.1 instead of 172.0.0.1, no?

Things to check on Jive:

when you installed Jive did you disable SSL (I think its enabled by default), if you didn’'t >you may have to use the “Show more options” in Gaim account page. I would not use >SSL by default as it brings other complications

Assuming this is done by changing the value of the property xmpp.socket.ssl.active to “false”, I just did that and still doesn’'t work.

oops…

127.0.0.1, did you try your computer name instead?

Conor.

Yes, I did try the computer name without success.

I just did another JM installation on a remote machine, and the problem persists.

I was wondering if any of the Jabber clients had some logging capability that could help me locating the cause of the problem? Because a “Couldn’'t connect to host” message doesn’'t help much.

Thanks

I switched to the Psi client and it is working perfectly. Look like my JM server doesn’'t like Exodus and Gaim

What is your computer’‘s name? Is it really 127.0.0.1? Never tried to put IP in name field. I think Windows should not let you enter such name, but i’'m not sure. So in Exodus in JID you should specify: username@computer_name or username@127.0.0.1

Both should work.

Hi Matheus,

I just downloaded the latest Jive Messenger 2.2.0 and Gaim, installed both (disabled xmpp over SSL at install) and registered a new user through Gaim.

Gaim/JM certainly work together. I even tried the localhost ip 127.0.0.1, so I can’'t figure out why you are having this issue, is there anything in your JM logs or perhaps you can have a look at the debug output from Gaim.

Cheers,

Conor.

I have just installed JM 2.1.5. From one machine, I tried GAIM 1.4 and it worked perfectly. From another machine, I could not get GAIM to work, but PSI jabber client works perfectly. I turned on logging on the server and could see that, in the case of GAIM, connection attempts were not even reaching the server. Firewall problems are presumably ruled out, as PSI can connect - although the firewall can block a specific program. So I turned off all firewalling and tried again. Same problem. Connecting to another service (AOL) worked fine. My conclusion is that there is some dependency in GAIM that is specific to Jabber which causes it to not function properly on certain windows boxes (in my case, both boxes are running XP Pro SP2)

Well, in my case at least, the problem really was Norton Internet Security. Turning off the firewall wasn’'t good enough, if I exited the program entirely, then everything was OK. God I hate Norton!!!