powered by Jive Software

Newbie. Fresh install. Admin console not accepting password

Hello everyone. I am new to the ignite community. This is my first post and forgive me if this problem has been solved already. I did a search and couldn’t fix it.

I downloaded Openfire a few days ago after seeing it in Website magazine. I admin a small network at a school and was looking for some easy to use communications software so this seemed to fit the bill.

On to the problem: I did a Installed Openspark on a Dell with XPP SP3. I chose embedded DB, set the IP address, and set the email and password for admin account. I went to login to the administrative console and got an error saying my username or password was incorrect. I know my password and the screen said the administrative login was “admin”. Did I miss a step? Is there a bug with SP3 on XP? Any help would be appreciated. P.S.: I can login to the Spark client just fine.

This should be related to JM-1537. A restart of Openfire should help.

I guess I should have said I tried stopping it and starting it again. I also closed it and reopened it and still wouldn’t allow access.

Hi,

it may help to shutdown Openfire and edit the embedded-db\openfire.script file. Look for

INSERT INTO OFPROPERTY VALUES(‘xmpp.domain’,‘your_xmpp_domain’)

Insert there a line like this if it does not exist:

INSERT INTO OFPROPERTY VALUES(‘admin.authorizedJIDs’,‘admin@your_xmpp_domain’)

This should make sure that admin@your_xmpp_domain can login.

As you can login with “admin” using Spark I suspect that the password is right. Anyhow if you want to change the admin password to “private” you need to change the line

INSERT INTO OFUSER VALUES(‘admin’,NULL,‘dn8669C8s’,…

to

INSERT INTO OFUSER VALUES(‘admin’,‘private’,NULL,…

LG

That file does not exist. “openfire.lck” “openfire.properties” “openfire.log” are all that is in that folder.

Text From Section
**
INSERT INTO OFUSER VALUES(‘admin’,‘admin’,NULL,‘Administrator’,‘admin@example.com’,‘0’,‘0’)
INSERT INTO OFMUCSERVICE VALUES(1,‘conference’,NULL,0)
/C3/INSERT INTO OFPROPERTY VALUES(‘passwordKey’,‘SIVoLuPqrR9uShC’)
/C1/DELETE FROM OFUSER WHERE USERNAME='admin’
INSERT INTO OFUSER VALUES(‘admin’,NULL,‘e20567c43cf302e5728c46be6eaacebb2375ce6f89c8679b’,‘Adminis trator’,‘admin@example.com’,‘0’,‘0’)
/C2/DELETE FROM OFUSER WHERE USERNAME='admin’
INSERT INTO OFUSER VALUES(‘admin’,NULL,‘e20567c43cf302e5728c46be6eaacebb2375ce6f89c8679b’,‘Adminis trator’,'
@.com’,‘0’,‘0’)
/C3/DELETE FROM OFUSER WHERE USERNAME='admin’
INSERT INTO OFUSER VALUES(‘admin’,NULL,‘e20567c43cf302e5728c46be6eaacebb2375ce6f89c8679b’,‘Adminis trator’,'
@.com’,‘001245080935665’,‘0’)
/C1/DELETE FROM OFUSER WHERE USERNAME='admin’
INSERT INTO OFUSER VALUES(‘admin’,NULL,‘e20567c43cf302e5728c46be6eaacebb2375ce6f89c8679b’,‘Adminis trator’,'
@
*****.com’,‘001245080935665’,‘0’)
/C2/INSERT INTO OFPROPERTY VALUES(‘xmpp.socket.ssl.active’,‘true’)
/C3/INSERT INTO OFPROPERTY VALUES(‘xmpp.domain’,‘192.168.15.102’)
/C1/INSERT INTO OFPROPERTY VALUES(‘provider.admin.className’,‘org.jivesoftware.openfire.admin.DefaultAdmin Provider’)
/C2/INSERT INTO OFPROPERTY VALUES(‘provider.lockout.className’,‘org.jivesoftware.openfire.lockout.DefaultL ockOutProvider’)
/C3/INSERT INTO OFPROPERTY VALUES(‘provider.user.className’,‘org.jivesoftware.openfire.user.DefaultUserPro vider’)
/C1/INSERT INTO OFPROPERTY VALUES(‘provider.auth.className’,‘org.jivesoftware.openfire.auth.DefaultAuthPro vider’)
/C2/INSERT INTO OFPROPERTY VALUES(‘xmpp.auth.anonymous’,‘true’)
/C3/INSERT INTO OFPROPERTY VALUES(‘provider.group.className’,‘org.jivesoftware.openfire.group.DefaultGroup Provider’)
/C1/INSERT INTO OFPROPERTY VALUES(‘provider.vcard.className’,‘org.jivesoftware.openfire.vcard.DefaultVCard Provider’)
/C2/INSERT INTO OFPROPERTY VALUES(‘provider.securityAudit.className’,‘org.jivesoftware.openfire.security.D efaultSecurityAuditProvider’)
/C3/INSERT INTO OFPROPERTY VALUES(‘xmpp.session.conflict-limit’,‘0’)
/C2/INSERT INTO OFPUBSUBDEFAULTCONF VALUES(‘pubsub’,1,1,5120,0,-1,1,1,1,0,1,‘publishers’,1,‘open’,‘English’,NULL,‘a ll’,-1)
/C1/INSERT INTO OFPUBSUBDEFAULTCONF VALUES(‘pubsub’,0,0,0,0,0,1,1,1,0,0,‘publishers’,1,‘open’,‘English’,NULL,‘all’, -1)
/C3/SET AUTOCOMMIT FALSE

We run our install using mysql. We experienced the same problem and noticed that if we did a “flush privileges” to the mysql db, then the login would work. I think this is what the restart actually just forces this flush. Just my theory - I could be wrong. Maybe the sql-install scripts need to include the “flush” command.

I was really hopeing it was something simple. I am using the embeded DB so I don’t know why type it uses. I really want to avoid having to install another DB as the server this will eventually be going on already has a MSSQL server running.

Hi,

during a proper shutdown (or startup?) the openfire.log file should be converted to openfire.script. As long as you have only the .log file you may edit it.

You may want to replace the IP address in “INSERT INTO OFPROPERTY VALUES(‘xmpp.domain’,‘192.168.15.102’)” with a full qualified domain name (like xmpp-test.example.com).

LG

I’d seriously consider adding a DB for use with Openfire.I’m using MySQL with OF, and it comes quite handy when you forget or lose the password and you need to change it. Plus, it handles heavier use than the internal DB.

Anyway, when using the internal database, it happened to me sometimes that the console won’t accept my password, so I simply edit the conf/openfire.xml, and look for:

true

and set it to:

false

You restart the server and you’ll be able to set the password again.

  • Another option:

Look for the embedded DB, and search for the Admin user entry, and replace the password (coded with MD5, I believe) using something like http://www.iwebtool.com/md5

I’m not sure why you don’t have the script file, as I recently installed Openfire as well (on a similar setup), and at probably about the same time as you.

Lucky for me, the solution listed above to insertthe admin.authorizedJIDs worked.

Until discovering this, I had to follow the following procedure. Not a great solution, but maybe it will work for you?

  1. Start up Openfire
  2. Wait until the server announces that the admin console is listening.
  3. Install and start the windows service, i.e.

C:\development\Openfire\bin>openfire-service.exe /install
Installed service ‘Openfire’.

C:\development\Openfire\bin>openfire-service.exe /start
Starting service ‘Openfire’.

I’m not sure why, but I needed both running, so I had a script that started them in proper sequence. After that I could log in.

Also the internal database is HSQLDB (http://hsqldb.org/), which is actually pretty fast, but has a very limited capacity (8 GB I think) and is harder to maintain since interaction is done through Java calls as far as I know. Also, it’s speediness may be limited to smaller datasets only, though I’m not really sure on this.

After a lot of trying and thread bumps I finnaly got into the back end! Your tid bit worked: changing it to false to reset the setup phase.

I restarted the server and it let me in.

Thanks a lot!

3.6.4 is definitely broken in this regard.

i’m running a 3.6.3 install at my company, have been for about a year (through several upgrades). i know my way around openfire. this is on centos 5.x.

i just created a centos vm on my home solaris server, and have installed assorted apps on it. decided to give 3.6.4 a whirl there. using mysql backend db. went through setup just fine, entered admin password, setup complete, attempt to log in to admin console - no way, baby. tried all the standard tricks, even re-established the admin pw using phpmyadmin. nothin.

since this was a brand new install, i figured screw it - i’ll just download 3.6.3 and see what happens. exact same steps, except absolutely NO problem logging into the admin console at the end.

it’s a shame openfire doesn’t have more support. that’s not a slam at the existing developers at all - you guys rock. but there’s clearly not much in the way of momentum on this project. it’s a great IM server, my company uses, and everyone loves it.