No access to group chat outside of localhost. help me fix today please?

hey folks,

I can enter the group chat room that i have created when i do so from localhost just fine. When i try to do so from another computer on my network, i can’t.

I’m running openfire 3.6.1 on a linux machine.

Server Name:

Java Version: 1.6.0_10 Sun Microsystems Inc. – Java HotSpot™ 64-Bit Server VM
Appserver: jetty-6.1.x

OS / Hardware: Linux / amd6

Group chat service name: clowder

My server to server settings are enabled on port 5269 and i have that open in my router. I have created a chatroom called bebuis on my server. It has the following options set to true:

Allow Occupants to Invite Others

Allow Occupants to change Subject

Allow Occupants to change nicknames

Allow Users to register with the room

Broadcast presence for (all three are checked)

When i try to connect from another user ( using room:bebuis, server:, nick:msandor) i get the message: There was an error processing your request for groupchat (reason: no reason given by the server. code: 404)

Since i can connect at local host i’m guessing this is a “should be open to the network but isn’t” problem. Anyone have any ideas on what else i can check?

Thanks a lot. I kinda need to get this fixed today.

Also, i have logging on, but nothing about this failed connection is reported in my logs. For what it’s worth i have clowder in my dns and that resolves.

My server to server settings are enabled on port 5269 and i have that open in my router.
You will also need to open client ports (5222 and 5223).

Ok here are some points i need to get clarified:

  • Chat server name on the server info screen (not the conference service)
    • This should be a fully qualified domain name such as
    • This is also the XMPP name also under system properties
    • This is also the name on the server certificates
  • Conference service name
  • Is the server name entered into your external DNS
  • Your conference service is not entered into the external DNS (it should not be)


On niether the server info screen ( or the server properties page ( is there a “Chat server name”. There is no under server properties. The xmpp.domain is “” and on the server info screen it states Server Name:

i realise that may be what you are talking about anyway, but i’m trying to be explicit here. :")

The hosts on the server certificates are,,,,,, (feline-soul.net_1) according to the server certificate page. That page also tells me “One or more certificates are missing. Click here to generate self-signed certificates or here to import a signed certificate and its private key.” but i’ve not had a problem using the server for im.

The conference service name is clowder

The server name is in the external DNS. My conference service is not in the external DNS (bind).

Verify that you have all the ports open/forwarded in the router that are listed in the server info page (except the management ports). Make sure they are fully open in the server firewall as well.

all three are open. thanks.

my guess is that you are having issues due to your naming convention. the openfire server itself should have a fully qualifided domain name. right now it has the name of the domain. this is not the same. you should also get rid of any certificates in openfire that do not match the Server Name, and xmpp.domain.

So if i named it would that mean that people would have to add me to their rosters as instead of (which i prefer)?

if i change it now will it mess up all of my message logs and the rosters of people that i am in? I’d like to know before i test this.


Yes to all. It will mess everything up. You can also solve this on the DNS side by making sure all your settings are correct.

If this is beyond the scope of the help here, i can ask elsewhere. What would i need to make sure happens in my DNS for to work? I’d rather not have to re-build a few years of IMing and my hundreds of contacts will be very annoyed if i change my address around.


What it boils down to is you have not given your server a real name (i.e. Because it is named only as, which is usually used for web servers you need to be sure you have srv records set correctly in your DNS to allow traffic to arrive at the proper destination. without these entries in your dns the traffic will not resolve correctly. There are other threads in the community dealing with srv records. i do not have much first hand knowledge here as I use a FQDN for all servers.

awesome Todd! That was the answer. I researched SRV records for sip and xmmp and put them in my bind server. It’s all working just fine and i can join my own chatroom from other networks.