No AD group in Roster

I have configured openfire 3.5.1 to talk to MS Sql server and Active directory. I can see all the users and groups in Openfire but when I logon to

spark 2.5.8 with my Domain ID(AD id) and password, I can’t see any of the groups in roster. How can I fix that.


Did you share one or more of the groups in the openfire admin console. you need to give them a name when you share them and if you are not a member of the group you will not see it unless you extend permissions.

I have enabled the contact list group sharing giving it a share name but it still nothing appears in roster. I have tried it on few groups of which I am member

but nothing appears. I have tried some other users and their groups as well but still no result. Though I can see them in openfire console.

Will appreciate the reply.

are there any errors in your openfire logs or spark logs? can you post your openfire.xml file (modified for security)? can you also provide a screenshot of the group your shared?

Thanks for your prompt reply. I have attached the files as requested. One more thing, I can’t logon to openfire console with Administrator account

but I can logon with my user Id which I added as admin user, though the test settings with administrator DN was successful.

Just wondering if someone can resolve my problem. Can see all the groups and their members in openfire but nothing shows up in roster in Spark client.

First thing I noticed int he openfire.xml is that you set your database connections very high. You should not need to do this. That number does not mean the number of users connecting to openfire.

Your openfire error log does not contain anything that I noticed that would be related to this error.

Do you have the screen capture of the shared group?

Are there any errors in the logs for spark? Spark errors can reside in 2 places: %userprofile%\Spark\logs and C:\Program Files\Spark\Logs

The user IDs you can used to access the admin console are the ones you entered during the setup. They are listed in the openfire.xml at <authorizedUsernames>adminuser</authorizedUsernames>

Thanks for your help. I can see all groups when logging on to spark.

Your welcome…

What was the solution?

Don’t forget to award points for helpful and correct answers.

I uninstalled the Spark client. Removed the folders from C:\program files and also C:\documents and settings\user profile. Reinstalled it and I could see all the groups. I added the administrator account to authorized user list under openfire.xml file as you suggested to login as administrator to openfire console.

Don’t know how to award points to you.

Each of my messages back to you should have buttons for helpful or correct answers. You need to be logged in to see them though. Pictures are in the attachment.

Clicked on Correct Answer as suggested. Thanks for your help.