powered by Jive Software

No Admin-Console, only Setup Process after Rebooting the whole server!?

Hi there,

I got a working Openfire 3.3.1 installation running on my linux machine.

Today i had to restart the whole Server (Not only the Openfire process or the Apache module).

The reboot worked out well.

Openfire starts up normally and i can log in via Spark - all contacts and the whole chatting procedure is still available. But if i try to log into my Admin-console via the normal way https://my-server.com:9091/ i do not get the log in panel - i get the setup-routine like i installed openfire the first time.

Help! What can i do to stick back to my normal Admin-Console?

Trying to go through the Setup will not work because after step 3 (database-choice) nothing happened…

Any idea?

Thanks in advance!

If your running a *nix os, especially redhat or Fedora Core, if you ran the ./redhat-postinstall.sh file you’'ll need to make sure that the config xml file is owned by jive, not by root.

Otherwise the jive user can’'t read a file owned by root.

If that’'s not the case, open up the config file and make sure is down near the end of the file

I am running Suse Linux.

Below i attach my openfire.xml which is based under the conf directory.

is at the bottom of the file.

Unordinary it is a openfire installation but in this file the serverurl ends up with wildfire ??

Any idea?

Tanks.

Hi,

do you see errors in the log file during startup?

LG

No, there are no errors in the log file.

But i saw more than 10 threads running “…openfire/lib/sartup.jar” - i killed them all. Fired up openfire again and -tada- all proceed as normal.

Server running. Admin console is reachable on no errors occured.

I am glad this is worked out. Thanks all for your help.