No JVM Could be found on your System

I am running Windows 8.1 x64 and Spark worked for about a week and then just decided to stop working. When I went to open it it gave me a JVM error. So i’ve re-installed and it still is not working

Steps I’ve done:

-Re-installed Java

-Re-installed Spark

-Tried loading the unbundled spark and pointing to the Java install

-Tried loading the JDK just to try

I’ve attached the log that gets spit out whenever it fails to load (880 Bytes)

Trying to guess what have happened. Are you using 2.6.3? Maybe Java on your PC has automatically updated from 7 to 8 version and Spark 2.6.3 can’t recognize 8 version of Java. Though you’ve said you have tried installing bundled version and this should work.

Anyway, you can try the latest nightly build (bundled one, not the online) of Spark and see if it works ok. all4j/

Thanks for the response!

Spark 2.6.3

Java 7 Update 60

I found the startup.jar in the lib folder and opened spark that way.

Verify class path “java_home”. JVM could not be found even class path variables changed after re installation.

I tried manually setting that class path with no luck.

The only way that I can get spark to open now is to open the startup.jar file directly in the lib folder

All my locally installed JVMs are 64-bit and Spark is asking for a 32bit JVM - that is the issue.

For now - I will simply use the offline installer.