powered by Jive Software

No logs generated

Hi guys,

Did a clean install of Openfire 3.8.0 and there are no log files being created. I assume there is something simple I am missing. I tried running Openfire as root to make sure I have all the rights but still no go. Not even turnning on Debug logs generate anything. Any helps would be appreciated!

Ubuntu 12.04 Server (Only OpenSSH installed after clean server install)

java version “1.6.0_24”

Openfire 3.8.0 (the tar file)

Thanks

Petter

Interesting. Openfire should be using a location relative to openfireHome to log. Is openfireHome set (when you start Openfire, do you see -DopenfireHome=(somevalue) in your processlist)?

In openfireHome/lib/ you will find a file named log4j.xml - this is where is configured what location is to be used for logging. You could manually tweak things there.

Hi,

I do see -DopenfireHome=/opt/openfire/bin/…/ and I assume it should be generating the logs in the log dir unless I am missing something.

Interestingly, setting the log locations manually did fix this problem. Not a big deal to me as I will not keep changing things but it does seem to be a problem.

Thanks

Petter

Thanks for posting this. Manually setting the openfireHome path in log4j.xml solved my problem as well.

I also confirmed that DopenfireHome is properly set. I imagine this is a bug.

This is fixed in the upcoming next release of Openfire, OF-640

On the latest 4.0.4 the logs are still not working, I am installing on Debian jessie. Any help please.

How did you install, via the .deb file? Where are you looking for logs? Do any appear on the admin console?

Thanks for reply.

I see that in log4j.xml path entries are correct e.g. my openfire home dir is /var/lib/openfire. then entries in log4j.xml is /var/lib/openfire/logs/error.log etc.

Also checked the permissions of dir and files.

I manually changed the paths in log4j.xml to new location-> /home/user1/logs.

Restarted the Openfire server.

All log files got created in /home/user1/logs/ but no log entries in the files.

In my config i’ve debug true in log settings.

Any suggestions, I am on debian8 and jre8

Which user owns the log files? Which user is shown as running the Openfire process?