powered by Jive Software

No mechanisms listed in sasl return stanza

Hello, I am trying to establish a secure connection with an Openfire Server (v 3.6.3) using server to server protocol. My server is configured to require connection security, and to accept self-signed certs (which are what I’m using). My TLS handshaking process appears to be working fine, the problem I’m having is when I move onto sasl. So… at the beginning of the sasl sequence, I initiate a new stream with a stanza that looks like this:

<stream:stream

xmlns=‘jabber:server’

 xmlns:stream='[http://etherx.jabber.org/streams](http://etherx.jabber.org/streams)'

to=‘vm3’

version=‘1.0’>

and the server returns a packet that looks like this:

<?xml version='1.0' encoding='UTF-8' ?>

<stream:stream

 xmlns:stream='[http://etherx.jabber.org/streams](http://etherx.jabber.org/streams)'

xmlns=‘jabber:server’

xmlns:db=‘jabber:server:dialback’

from=‘vm3’

id=‘e682f977’

xml:lang=‘null’

version=‘1.0’>

stream:features

</stream:features>

when I send the server back an auth header:

it just ends the stream </stream:stream>

It appears that my server does not have any sasl mechanisms that are supported. It also seems strange that I have a mechanisms header here for dialback… don’t know if that’s important. I’ve been searching around trying to figure out how to add these mecahnisms (ex PLAIN, EXTERNAL…) I’ve seen a lot of talk about altering the openfire.xml file like so:

PLAIN

… (other stuff taht was already here)

This seems to add an option to Properties inside the Openfire Console for sasl.mechs PLAIN, however that option is still not showing up in my sasl stanzas.

Any suggestions as how to add sasl mechanisms? I am currently using the Embedded Database (don’t know if that’s an issue).

Thanks in advance.